More and different problems with "save as" dialog

Shane and Mark,

I am having a problem similar to the 1 listed in the post linked below

I started off with an enhanced Application applet (titled “Test”) that was working. I copied the script code into another empty SD document. It seemed to paste without any errors. Then I did a “Save As” so I could save it as an enhanced Application, and as in the previous post I linked at the beginning of this post, I got the same grayed out check box, but this time when I clicked “Stay Open” the “Show Startup screen” remained dim and I could not turn off the “Show Startup Screen.”


This time I tried logging out and back into my account to see if shutting down all the user processes and starting them back up would help. The Applet still did the same. I wanted to see if this problem would persist if I saved it to a compiled script and then saved the compiled script as an Enhanced application. So I saved “” to “Test.scptd” and saved that to “Test” The same thing happened in the newly created Enhanced application. I tried “Save As” again to see if the problem was going to stay consistent and this time none of the stuff shown in the image above appeared. There was a hole where that stuff should have been. The darker gray that is behind the controls was there but there was no controls. When I tried “Save as” again there was no hole but I had the problem as shown in the image above.

Unfortunately I forgot to take a picture of the dialog with the missing controls. I tried doing many “save as” but I always got a dialog like the one shown in the image above after the time I got the hole.

So I created a zip file containing the 3 files: Test, Test.scptd and and uploaded it to this post. It appears something more complex is going on here then I first suspected.


Applet (3.1 MB)