ANNOUNCE: Script Debugger 8.0.5 (8A57)

A new Script Debugger 8.0.5 BETA build is available. You can download it here:

http://www.latenightsw.com/archives/beta_for_script_debugger/ScriptDebugger8.0.5-8A57.dmg

Script Debugger 8.0 Release Notes

Build 8A57 Changes

  • 1793: Enhanced applets no longer display a startup screen of the show startup option is off and there is no on open handler.

  • 1797: On-screen code formatting is not always appropriate for printing, especially in Dark Mode. Now you can define separate print-specific themes. You can do this by defining new themes with " Printing" appended to their names, or defining a universal printing theme called “Printing”. Full details are in the Script Debugger Help entry for Themes.

  • 1784: The Unfold command works correctly when unfolding a single selected line containing a fold.

  • 1802: Code Folding is no longer applied when opening documents when Script Debugger is operating in LITE mode.

  • 1799: Corrected a problem where a make new document command which specifies a source text property value does not returns a reference to the newly created document.

  • 1796: Improved the display of application errors in explorers to include error descriptions where possible in the absence of an error message provided by the application it’s self. Added the errAEEventNotPermitted error to the list of known error codes.

  • 1792: Eliminated thousands separator in error number appearing in the Script Error panel.

1 Like

Seems like the enhanced applet (with an open handler) stays open after running, even if Stay Open is not turned on.

This behaviour is the same in SD 8.0.4.

An enhanced applet with at on open handler will present the drop-target window and wait for a file to be dropped. If stay open is off, the applet will quit after processing a single file.

Got it. So looking previous scripts I have a “tell me to quit” at the end of the run handler, but not at the end of the open handler. Both quit just fine.

Thanks

Does SD 8 run on macOS 13 betas? Obviously I wouldn’t expect it to work perfectly on a beta OS; just wanting to know if it’s generally useable. I’m looking to upgrade my dev machine to macOS 13 beta but if for some reason SD doesn’t launch or is otherwise unusable I wouldn’t want to upgrade.