SD 8 Repeatedly asks for "Full Disk Access"

I wonder if there are any lurkers using 12.3.1 who’d care to check where the file is on their system.

I would, but I no longer have a 12.3.1, that went back to the user, who has had numerous issues with it (a few related to appleScript).

12.3.1, Intel. Results from Find Any File. Notice the dates for the two locations. Presumably Apple moved the file to a new location? (The line blurred out is the file location for another user added to the system in the past few weeks; the location matches the newer location on my user account.):

Thanks for the feedback. I created a new user and the file appeared in neither place, so it’s clearly not the valid test it used to be.

I started having the same problem, about one to two weeks ago. I have tried all of the above solutions, but without success. To answer Shane’s questions:

  1. I have used version 7 before installing version 8
  2. I am running MacOS version 12.3.1
  3. File permission error
  4. No error

•I have rebooted with System Preferences/Security & Privacy/Privacy/Full Disk Access as well as Accessibility unchecked, and then checked them without success.
•I have no SD7 application or files in ~/Library/Application Support
•I have downloaded a fresh version of SD8.
When I double click the SD icon, I receive a dialog that Script Debugger quit unexpectedly

Please help

When I ran the script through Terminal, it responded

/Applications/Script\ Debugger.app/Contents/MacOS/Script\ Debugger ; exit; alan@MacBook-Pro ~ % /Applications/Script\ Debugger.app/Contents/MacOS/Script\ Debugger ; exit; 2022-05-15 20:15:30.139 Script Debugger[7104:61384] <RKApplicationList: 0x6000005d3540>: _applicationsQueryGatheringFinished: NSConcreteNotification 0x6000030bd840 {name = NSMetadataQueryDidFinishGatheringNotification; object = <NSMetadataQuery: 0x600001e0d300>} 2022-05-15 20:16:33.746 Script Debugger[7104:61384] Could not find image named 'RKPaid'. zsh: segmentation fault /Applications/Script\ Debugger.app/Contents/MacOS/Script\ Debugger

Might the lack of an image RKPaid be the problem for my SD8 opening problem?
If so, how can I correct this issue, as I had already paid for the SD 7 to 8 upgrade?

The Full Disk Access issue causes the dialog to appear, but it does not cause Script Debugger to quit. You have a different – and more serious – problem.

Please download a new copy of Script Debugger, and also do a system restart.