SD 8 Repeatedly asks for "Full Disk Access"

Hi - I just upgraded to version 8 from version 7.

When I first ran SD8 it told me that full disk access was required so I went into system preferences and added SD to the list. Then I restarted SD8.

The problem is, SD8 keeps prompting me to switch on full disk access - every time I run it which is a complete nuisance. Here’s the screen shot:

I’m running Mojave 10.14.6.

Can you provide a fix/workaround for this please asap? Thanks.

Do you still have version 7 installed? if so, try deleting it (make a .zip first), removing SD from the FDA list, and adding it again.

I am having the exact same problem. I have do not have SD7 on the drive. I have tried three times removing SD8 from FDA (once after restarting the computer). Same dialog pops up every time I launch SD8.

No, version 7’s gone…

Thanks for the detailed advice @scrutinizer but here’s a quote from something I just read about disabling SIP:

If you’re experiencing problems with kernel extensions or other software which are supposed now to be hardened and notarized, the problem isn’t with SIP, it’s with that third party software, and that is what you need to get fixed.

So I’ll wait for that fix from LNS :slightly_smiling_face:

EDIT: Oh! The post I replied to disappeared completely in the few minutes it took me to write the reply. If my post now looks out of place I was responding to the suggestion that disabling SIP would temporarily remove the issue.

I found a folder ~/Library/Application Support/Script Debugger 7 on my disk which I’ve deleted. After rebooting my Mac SD8 no longer asks me to enable FDA. I do not understand why that would solve the problem (or even if that is the solution) but now SD8 is working as expected.

I suspect the reboot was what did the job, but there’s clearly more to it.

For anyone else who sees this issue, here’s a bit more explanation, plus a request for feedback.

The dialog was introduced when Catalina came out, as described here:

We had a few reports of the dialog persisting then, but they went away. I suspect Apple ironed out some issues at their end, although we don’t think the underlying problem that lead to the need for the dialog has been fixed.

As it says in that thread, Apple has no API for testing whether Full Disk Access is on: they say you can only check a file by asking the file manager using isReadableFileAtPath:.

Our code does this with a file that we could not read without Full Disk Access. If the file exists, but the file manager says we can’t read it, we put up the dialog.

Importantly, the code used for this in Script Debugger 8 is exactly the same code used in version 7.

So some questions for anyone who strikes the problem:

  1. Were you using version 7 before installing version 8?

  2. What version of macOS are you running?

  3. Do you get an error if you run this code, assuming you’re running Catalina or later:

set thePath to (path to library folder from user domain as text) & "Safari:CloudTabs.db"
set theData to read (thePath as «class furl») for 3

And for Mojave users:

set thePath to (path to library folder from user domain as text) & "Safari:Bookmarks.plist"
set theData to read (thePath as «class furl») for 3
  1. Have you received any “Cannot save document” errors -54 or -43 when saving a .scpt file?

We’d dearly like to get rid of the dialog, but we don’t want people being unable to save.

Thank you.

I’d agree normally, but there were 3 other reboots before that one!!

Just for completeness, my responses are:

  1. Yes, I was on version 7
  2. Mojave, 10.14.6
  3. No error
  4. Never received such errors

Hope that helps…

Yes, that’s the frustrating thing.

1 Like

I had the same problem during the beta test when I still had Script Debugger 7 installed.
After deleting the ~/Library/Application Support/Script Debugger 7 folder, removing all entries in the system preferences and rebooting the Mac, it disappeared.
No problems since then.

1 Like

I’ve read elsewhere that if this happens, remove the app (Script Debugger) from Full Disk Access, reboot, then add it back in. I’ve used this technique before, with success.

Remove from Full Disk Access, reboot, re-add to Full Disk Access worked for me for Script Debugger 8, too.

Getting FDA to work is a bit like standing on your toes, spinning around, and clicking your ruby red slippers to get the wish granted. Thank you, Apple!

1 Like

The problem is affected me as well
MacOS 10.14.6
Was using ScriptDebugger 7 (and 6)
Installed Script Debugger 8 without removing Script Debugger 7 (i.e. as an upgrade)
No problems or error messages before the upgrade.

Removing S.D. from Security Preferences, and then adding S.D. again did not work.

What worked was the “hammer”: removed S.D. from Full Disk Access and Accessibility, then a safe boot, removed S.D.7 and S.D.6 files from the library, Then reboot.

btw this terminal command will efficiently list every Script Debugger file and folder in your system, an expected error message is rejected, all others passed.

sudo find . -iname “latenightsw” 2>&1 | grep -iv “operation not permitted”

1 Like