Re: Typing in reverse

I tried to add a comment to this thread but it auto-closed 18 hours ago.

I’m having the same problem, however, deleting com.latenightsw.ScriptDebugger8.plist file in the ~/Library/Preferences folder has not had any effect. I’ve tried it multiple times and have restarted my Mac.

I didn’t have the problem prior to installing the latest release a few days ago. Initially, I thought it was a new preference setting, but when I couldn’t find it initially, I suffered through it for a day or two with some minor edits.

I checked the archives to find an old version, but cannot find an older version of 8.x. I reinstalled 7.x and it works but I’d rather not go back that far. Could I get access to version 8.0.5 (8A57) or earlier?

Hi, Jim!

I’m sure you know that, but just in case: you should completely exit SD, before deleting com.latenightsw.ScriptDebugger8.plist file


Thanks for the response. I wish it was a simple fix and I overlooked that step, but I did quit SD first. After it didn’t work the first time, I downloaded a fresh copy of the app too. That’s when I tried a full restart.

@mark - If it’s helpful, I am running an old OS - 10.15.7


Hi Mark - No claims that this is the fix, but this is what worked for me.

As I mentioned in the original post, I reverted back to v7.x. Not sure if it’s relevant, but v7.x launched without prompting for a serial number. l’d guess com.latenightsw.ScriptDebugger7.plist was still in the preferences folder.

I found an old copy of SD 8.0.3 on a backup and copied it to my Mac. Before launching 8.0.3, I made sure com.latenightsw.ScriptDebugger7.plist and com.latenightsw.ScriptDebugger8.plist were deleted.This time 8.0.3 not only prompted me for v8 serial number, it also prompted for v7 as well.

I tested v8.0.3 and it worked as expected. Since I don’t like to give up, I used the in-app installer to upgrade to v8.0.5. Relaunched it and SD is happy again.

Although frustrating, a win is a win. Hopefully this helps you, or someone else with this problem, troubleshoot it.

This is the same problem referenced in this topic:

I’ve addressed this problem in the Script Debugger 8.0.6 maintenance release. A beta build is available here: