ANNOUNCE: Script Debugger 8.0.7 (8A75)

A new Script Debugger 8.0.7 BETA build is available. You can download the new build here:

Script Debugger 8.0 Release Notes

Build 8A75 Changes

  • 1846: Resolved a problem where Script Debugger does not recognize script documents and applets stored on OneDrive and other file services that do not properly provide legacy HFS filetype and creator codes.

  • 1845: Resolved a series of issues with the Help menu:

    • The Open Help In Browser menu item once again works.
    • The Script Debugger Release Notes menu item takes you to the correct web page for Script Debugger 8.
  • 1843: Resolved a problem launching Script Debugger on Monterey and Big Sur systems.

  • 1842: Addressed a problem where Script Debugger incorrectly detects changes to a local variable when debugging is enabled.

Build 8A73 Changes

  • 1840: Fixed issue where Notarize button may fail to appear when exporting if both SD Notary and SD Notary 2 are present.

  • 1841: Addressed a hang that may occur when inserting a newline into a block comment.


Downloaded and tried it out and it’s not crashing on Mohave right off the bat. So YIPPEEEE.

Thanks very much for getting it working…


1 Like

This is odd. I recently upgraded mac OS and installed this new beta.

First when it launched I got the expiring beta warning. (March 1 seems pretty quick)

I was running the mail app and tried to open a script in the Fast Scripts menu by option-selecting it.

The script seemed to open, but the window was blank. It ran just fine. If I clicked debugging it seemed to switch to debugging mode, but I couldn’t see any of the script, just a blank window.

I’ll relaunch and try a few more scripts.
→ Mac OS: 14.3.1 (23D60)
→ Script Debugger 8.0.7 (8A73)
→ SD Notary 2 2.0 (102)
→ FastScripts 3.2.7 (1767)

OK, Reinstalled, and now the version number is correct and everything seems to be working.

→ Mac OS: 14.3.1 (23D60)
→ Script Debugger 8.0.7 (8A75)
→ SD Notary 2 2.0 (102)
→ FastScripts 3.2.7 (1767)

I was glad to see this update had been released. It resolved two issues with the prior Beta (8A73). Specifically, in that version, when the Toolbar was open the editor and Result and Variables panes were black; no interaction could occur and no text or other elements were visible. Secondly, it was not possible to restore a prior version using File > Revert To.

Mac Studio M2 Ultra
macOS 14.3.1
Script Debugger 8.0.7 (8A75)

I noticed two problems with the tool bar in the script window and the debugging window.

First, the three-buttons for the variables, resources and inspector tags disappeared from both tool bars. (I haven’t changed my tool bar in years).

Second, when I put them back the flexible space in the tool bar behaved different from before.

It used to be that when the window was wide enough a flexible space before the timer would center it in the window and another flexible space would move the icons after it to a flush right position.

Now the flexible space seems inconsistent. Sometimes it makes a too long space, sometimes not enough, but I can’t seem to get back the smooth and consistent look my tool bars have had for years.

→ Mac OS: 14.3.1 (23D60)
→ Script Debugger 8.0.7 (8A75)

I don’t think we made any changes to the toolbar’s behavior – that all sounds like OS changes. (We had to make changes elsewhere in response to changed toolbar behavior, but they’re unrelated to your issues).

Either way, the flexible space thing is broken.

Also, when I try to make changes, it ends up putting spaces and icons in different places, all related to the flexible space thing.

I wonder if anyone else is seeing the same thing?

After installing version 8.0.7 (8A75), the group of three “Show” buttons you mentioned were still present and functioning. I tried a few uses of adding flexible spaces and they all preformed normally.

You referred to “both tool bars”. I know of one, on the main window containing the editor, et. al. To what were you referring as the second tool bar.

You could try customizing the tool bar by putting the default back, then resetting it to your liking. I know you are an experienced user (notice I avoided the term “old user” :slight_smile: which could also apply to myself) so you may have already tried.


Mac Studio M2 Ultra
macOS 14.3.1
Script Debugger 8.0.7 (8A75)

The tool bar is different when in debugging mode. That’s what I was referring to.

I noticed that the three “show” buttons were not present, in the tool bar, but were grayed out in the icons. I was still able to drag them in place.

Yes, I did try restoring the default and that didn’t work.

Yes, there are two toolbars. It’s been that way since Script Debugger v4.

As for the flexible space toolbar item, can you make a vide illustrating what you feel is wrong. Frankly, this is all done for us by macOS so I’m not sure I can correct the problem but I would like to understand it.