Xcode provisioning profile not showing up as option in Script Debugger

It did on macOS 10.15.7.

Now I have a machine with macOS 11.6 and repeated the steps of signing into Xcode, downloading the profile, and then opening Script Debugger (full license of version 8), but I only have the “Sign to run locally” option there.

Am I doing something wrong? Thanks.

You also need the relevant certificate in your local keychain.

I see. Weird that I don’t seem to need this on Catalina.

I made the profile by signing in to Xcode with my Apple ID.

How do I transfer that profile to my local keychain? I’ve spent the past few days trying to look for articles on this.

(I am aware of this article but it doesn’t outline this specifically.)

Have you been through Apple’s documentation?


Also, if you log in to your developer account, you can get support on certificates from Apple via email.

(I can’t answer your specific question because it’s so long since I did it, I really can’t remember the details.)

After reading up on the Apple documentation, I’ve concluded that signing in with the Apple ID in Xcode is supposed to automatically add the certificate to the keychain.

I just checked, and it’s already in my keychain. So I’m not sure why it’s not showing up in Script Debugger. Especially since it does show up on the Catalina system, but not on the Big Sur system.

Can you try running the following in Terminal:

security find-identity -p codesigning -v

and email me the result?

On the Catalina machine, it returns 1 valid identity found and lists its info, but on the Big Sur machine, it strangely returns 0 valid identities found. I’ve tried exporting and importing the certificates between the machines, to no luck.

Are you exporting them in Personal Information Exchange format (.p12 file)?

I am, yes.

Am I perhaps importing/installing them incorrectly? I have tried both through Xcode, as well as opening the .p12 directly with Keychain Access.

Are you sure you’re exporting/importing the right certificate(s)?

I had a similar problem with Bug Sur. The import and export with the keychain was supposedly successful, but I could not use the certificates, because the private keys were not present. I could not import these.

I then did the export directly from Xcode and then the certificates were imported correctly.

I did the export and import both with Xcode, in the Accounts section of Xcode Preferences.

I only have one certificate in Xcode on Catalina, and I export it by right-clicking on it in “Manage Certificates,” and then import it on the Big Sur installation by clicking the gear, and then “Import Apple ID and Code Signing Assets…”

Still doesn’t work on Big Sur (Terminal returns 0 valid identities, and Script Debugger shows nothing).