Why Does Is This Property No Longer Available?

A number of years ago I wrote a Messages application AppleScript and it worked great.

I re-ran the script a week or so ago only to discover the script would not run. The offending part of the code – a noted below – was my attempt to access the Participant property of the Chats class which produced error -1728 is as follows:

tell application "Messages"

   set myChats to chats

   repeat with aChat in myChats
      set aParticpant to participants of aChat
      log aParticipant       
   end repeat   
end tell

I was about to give up when I decided to download Script Debugger to see whether it could provide additional insight.

I was shocked how fantastic Script Debugger was at identifying the problem which is illustrated in the attached screen print.

It is my understanding that the Participant property of the Chat class is no longer accessible / available.

Would very much appreciate responses to the following:

  1. Am I correct that the Participant property of the Chat class is no longer accessible / available?

  2. And, if I am correct, then how / why would this happen and is there a workaround?

Thank you.

PS. Script Debugger is great! I am definitely ditching AppleScript! All I can say is that I wish I would have tried this app earlier, I would have saved tons of time!

What you see depends on the version of macOS, I suspect. Under Monterey, participants are available – but most of the other properties have been removed.

@ShaneStanley , thank you much appreciated.

I am stuck on Catalina because of the age of my MacBook Air but a MacBook Pro is on its way to me so hopefully it will work with Monterey.

Once again, thanks!