Ventura - not authorised to send apple events to Music

In the last 2 updates of Ventura, I am not able to run Apple Scripts in Script Debugger. The GUI has changed. And furthermore I do not get a pop-up asking if I would like to allow Script Debugger or Apple Events to control my MacBook. This Pop-up did occur when I ran the same script through script editor. Script Editor will run the same script no worries there.

As I understand, we need add permissions for Script Debugger to include the following:

  • Privacy & Security >>> Full Disk Access >>> Script Debugger added and switched ON
  • Privacy & Security >>> Accessibility >>> Script Debugger added and switched ON
  • Privacy & Security >>> Automation (cannot manually add apps here, they need to have a pop-up)

The note in the Automation section displays the following:

Applications that have requested access to control other applications will appear here.

I have clean installed MacOS Ventura 13.4 (22F66) on an unsupported MacBook using Dortania OpenCore Legacy Patcher and all is working well, except this.

Although we don’t seem to see the same options they used to appear in the GUI, Script Debugger has been added and switched on Full Disk Access, Accessibility, although there is no way to add this to Automation via GUI where we would normally in previous MacOS versions tick to allow apple events.

When running my usual script through Script Debugger the error is:

AppleScript Execution Error: Not authorised to send Apple events to Music.

I’m hoping someone else has come across this and can provide some help?

Am I the last to the table to realise that MaCOS Ventura simply will not work with Script Debugger?
I see that it’s not supported. I will mention there was a time during first Ventura upgrade it was working. Potentially some of my plist settings were carried across during re-install.

It’s been working perfectly here with Ventura from the day Ventura was released until now. Maybe rename the SD8 folder in ~/Library/Application Support and try again?

is it possible that that’s the key to your issues:

Mark and Shane:

Perhaps the Requirements should say that SD is supported only on Macs running an OS version supported by Apple on that hardware? That way you won’t have to deal with problems on Hackintoshes, etc.

No disrespect to those who run unsupported systems and Hackintoshes - but I don’t think they care about the published requirements in the first place anyway.

@leo_r - You’re surely right, but at least it would give Mark and Shane a clear, publicly-visible reason not to spend their time trying to sort out problems that occur on machines running an OS version that Apple doesn’t support on the machine’s hardware.

1 Like

Well, you are wrong in your -no disrespect to you- arrogant and self centred assumptions. I also have the same problem as Mr Cee, and also am running a MacBook 2012 on Monterey using OCLP 0.6.6.

This is called feedback to Late Night Software and will also be provided to OCLP

If you have nothing constructive to say, then may I suggest you keep your opinions to yourself.

I have the same problem with Monterey 12.6.6 and OCLP 0.6.6

My problem is with Script Debugger not working with Numbers scripts -

Running Monterey 12.6.6, OCLP 0.6.6, Script Debugger 8.0.5, Numbers 13.0

My AS Numbers Scripts work fine with Apple’s Script Editor with the caveat that “Script Editor is not allowed to send keystrokes. number 1002” - eg - tell application “System Events” / key code 53 / end tell "

However, the same scripts with Script Debugger 8.0.5 do not even get started and instead I get the “SD is Not Authorised to send apple events to Numbers”. SD has full disk access.

Here’s a suggestion (if you haven’t already done this). After your next reboot open Script Debugger and run a script that you know won’t work.

Immediately go to System Preferences>Security & Privacy>Privacy>Automation

Look for Script Debugger, if it’s there and isn’t active, check the box.

The hope is that even though the popup alert doesn’t show, that the preference pane is still working.

If that doesn’t work then it may be that whole unsupported system thing.

Good luck.

1 Like

Ok so your reply exactly confirms everything I said in this thread. So thank you for confirming the validity and the constructive nature of my posts.

At this point it appears - as per OP and your post - that the issue is specific to running macOS under an unsupported configuration. The first troubleshooting step in this situation would be to install a supported version of macOS on you Mac and see if the problem persists. That’s how you isolate this particular issue.

Then it’s of course up to SD developers whether to look into this issue or not.

Script Debugger continued to work after I updated the MacOS to Ventura over / replacing old MacOS without clean install.
It maybe an oversight to say unsupported hardware is the root core of the problem.
In my update history, Script Debugger did work when retaining all the original plist and system files.
Clean install for me is when the problem began, and understanding that there are hardened rules that need to have values added to plist, perhaps this is the problem?

I don’t exactly understand what that means, sorry.

Normally, SD should work on any kind of install - clean or otherwise.

Like I mentioned in an earlier post, I believe that as the first troubleshooting step in your situation you need to install a supported macOS version on your Mac (on another partition or external drive).

If you have the same SD problem on the supported macOS then you have an evidence that unsupported system is not the root of the problem and investigate the problem further.

Otherwise, there’s a reason to assume that unsupported system can be the reason for the SD issues.

In my view, you need to do this step first, then decide what to do next. It’s quite possible that other users can offer a simpler solution.

Apologies for not being clear.
I have not upgraded the hardware. I have only updated MacOS in 2 ways. Once by overwriting old MacOS and everything worked well as system files were retained, and a few times doing a clean install where system files are built from scratch.

When I did the original update to Ventura on an unsupported MacBook Pro, system files were retained for Script Debugger and it continued to work.

Since wiping the hard drive clean with the same install, I have not been able to get Script Debugger to work again.

So to me, there is something not being written to a system file to allow it to work as usual after a clean install.

I cannot find or did not back-up old system files in Time Machine. That ship has sailed.

So this scenario is not ‘Normally’. Since clean install I cannot run any of Doug Adam’s scripts either. But will say I did not have a problem after MacOS update where I installed over the top of old MacOS.

If I look all over the net, the closest thing I can find is:
Do you have an NSAppleEventsUsageDescription string in its Info.plist file?
So I’m not sure if this is what is not being written to system files.

The best scenario would be to help me engage the MacOS pop-up that specifically asks for permission to Apple Events. This unfortunately does not happen in Ventura.

Has anyone else done a clean install, and if not did you install over the top of old MacOS and retain the system files this way… Is this how Script Debugger continues to work?

I did try that.

Not authorised to send Apple events to Music.

Where is Ventura on the list of requirements? It did work originally. Yes I do care and read requirements. Do the requirements stop at Big Sur? Really hoping for some help. Shane will look in to it.

Script Debugger 8 requires macOS X 10.14 (Mojave) or later. Script Debugger 8 fully supports macOS X 11 (Big Sur) and runs natively on M1 Macs.

The problem you describe does. not exist in a Ventura system running on hardware that officially supports Ventura. It does not occur on fresh Ventura installations where SD is newly installed, and it does not occur in upgraded installations where SD is already installed.

What is different about your system is that are running Ventura through OCLC, not on hardware that officially supports Ventura. That seems to be the problem, and there is probably no way around it without something getting fixed in OCLC itself.

But the only to find out for certain is to test on a version of macOS that is officially supported by Apple on your hardware.


@emendelson Something that may help others using OCLP: Do you think at this could have anything to do with having an intel chip or have you been able to test on other chips. It would be good to rule it out. Looking forward to your advice and thank you for your input.

I may be misunderstanding your question:

As far as I can tell OCLP is not needed and cannot be used on any M1 machines. This whole issue can only apply to OCLP running on Intel, because Intel is the only thing that OCLP runs on.

I tested with SD 8.0.5 sending Apple Events to Numbers under Ventura on my older Intel Mac and on my new M1 Mac. There is absolutely no problem with Ventura on hardware supported by Apple. No problem on Intel. No problem on M1. The problem seems only to occur on systems running OCLP.