Use Script Debugger to open all documents like this one (.scpt)

Finder won’t recognize Script Debugger as the owner of script files.

Whenever I double click on a file with .scpt extension it opens in Script Editor.

in Get Info for the file, Script Debugger is listed as “Default” under Open With, but Script Editor is the selected app, and I cannot seem to select any other application.

Is this a common issue? Or is it unique to me.

In Script Editor Preferences -> General, check the Default editor for... checkbox down the bottom.

I tried that but unfortunately it didn’t resolve the issue.

I finally figured it out. All my scripts were in the Script Editor folder in iCloud. The problem was that that’s not just like a normal folder, macOS forced everything contained within to be opened with Script Editor.

I moved my files to a new folder and now they’re fine.