Unable to print from script debugger

Does anyone else have problems printing from SD? When I try to print, via menu or kb shortcut, all I get is “beep”. (Yes, my license is entered.)
I’m running
ScriptDebugger 8.0.5,
MacOS Ventura 13.2.1
Printing results in the same bad behavior on 3 Macs:
2 Intel Machine, and 1 Apple Silicon M-1 machine.
Printing works on Apple’s Script Editor and all other apps.
Booting in safe mode does NOT solve the problem.

Which version of macOS and Script Debugger? There are no known bugs that stop printing.

Same thing here. I’ll try from my other system shortly.

→ Mac OS: 11.6.8 (20G730)
→ Script Debugger 8.0.5 (8A61)
→ FastScripts 3.2.4 (1738)

Same here. Even if I change the chosen printer.

MacOS 12.6.3 (21G419)
Script Debugger 8.0.5 (8A61)

I’m wondering if it’s something specific to a certain document configuration. Perhaps someone could make a short video so I can try to repliate things exactly.

I tried printing on my other mac, and it worked, but, the first time there was a long pause (5 seconds, then a beep then a short pause 2 seconds and then the print dialog.

Second time there was no delay.

Script Debugger 8.0.6 (8A64) on OSX 12.6.3

Printing in Script Debugger doesn’t work for me either. To reproduce:

  1. Open Script Debugger
  2. Enter “-- test” on the first line and then select the Enter key
  3. From the top menu select File > Print and nothing happens
  4. Select the Commmand + P key combination and nothing happens.

This is with Ventura 13.2.1 and Script Debugger 8.0.5.

Similar here. Open a New File, selecting AppleScript or Empty AppleScript as a template… In the first case, It’s populated automatically with 2 lines. Try to print. It doesn’t work. In the second case, enter the “–test” comment. It also doesn’t work.

1 Like

I re-tested printing here on my Monterey system and its working for me.

I’ve filed a bug for this issue at our end so we don’t lost track of this issue. Shane and I cannot reproduce the problem you are experiencing on our systems. Unfortunately a beep does not tell us why printing is failing for you. There is some sort of difference between your system and ours (other than OS version) and we need to discover what that is.

The fact that several people are experiencing this problem is promising as it suggests an issue that is not unique to @ikenassi .

Please run the Console utility application to view your system’s logs, and filter results on “debugger”. Then, print from Script Debugger and see if anything relating to printing is logged.

1 Like

The console remains empty.

I tried to print by script: the countdown starts but nothing else happens.
No window, no beep, no nothing…

1 Like

I responded directly in an email. The console shows very little information. I also tested this on Catalina (10.15.7) and had the same problem. I emailed the console log separately.

Same issue for me, macOS 13.2.1, Script Debugger 8.0.5 (8A61). I get an immediate beep when I try Command-P. Same when I choose File/Print… just a beep (no dialog box). Just adding another 13.2.1 macOS data point.

1 Like

I just upgraded to Ventura 13.3. The print problem persists. No difference.

We have implemented some fixes for this issue in the Script Debugger 8.0.6 8A66 pre-release build. Since Shane and I are unable to reproduce the problem, these changes are speculative. Please report back with your findings.

1 Like

Seems to be fixed.

Installed the new version. Opened a script and hit command-p. After a pause and beep the print dialog came up.

Second time no pause, no beep, just the print dialog.
→ Script Debugger 8.0.6 (8A66)

Just before installing the update, I tried printing and got the delay-beep-nothing the first time and beep-nothing the second

→ Script Debugger 8.0.5 (8A61)

I saw exactly the same behavior as @estockly estockly

This issue is fixed for me in the just-released version of SD 8.06. Thanks!