Team is not yet configured for notarization. Error

Hi All,

I’m tearing my hair out over this error I get when trying to notarize an app. Error that is returned is below. “status”: “Rejected”,
“statusSummary”: “Team is not yet configured for notarization. Please contact Developer Programs Support at under the topic Development and Technical / Other Development or Technical Questions.”,
“statusCode”: 7000,
I’ve have contacted Support some days ago but nothing yet wondering if any one has resolved this without Apple support. I’ve trying un-installing CLtools but nothing.


Have you logged in and agreed to Apple’s terms?

For the life of me I cant see any agreements that require submitting. Am I better of unenrolling and re-enrol, is that even possible. I have clients waiting for updated apps that I can notarise and no responses from apple.

Log in to your developer account and go to something like Support -> App Setup -> Binary Delivery and Processing. You can opt for phone support there.

1 Like

Support were unable to help as soon as I said using a thirdparty app to upload they didnt want to know about it, even though I said it was using xcode command line.

I tried submitting via command line and got the same error dont know what to do next.

Can you explain when exactly you get the error? A screenshot of the log might help.

But first, try creating a new app-specific password for notarytool.

(Just double-checking: you are using SD Notary 2?)

Hi Shane,

Usually, it uploads and after a few minutes SD log says failed when I choose File > Info for…> last submission it gives me the above error message. I tried submitting via xcrun in terminal and got same result.

In the past hour when trying to submit either via SD or xcrun its timing out or just showing In Progress .

I’m not sure how to reset SD to a new app-specific password.

yep using sd notary 2


Can we see the actual log? Send it to me privately, if that’s your concern, but I can’t suggest anything else without seeing exactly what you’re seeing.

Well I have no idea why but after a week of submissions being reject today they are being passed. Happy days!!

After all this I realise that the docs for SD Notary doesnt have info on how to reset the app to change the app-specific password.

Big thanks to Shane’s help in trying to trouble shoot all this both publicly and privately.

If your existing one fails (or doesn’t exist), you will automatically be prompted to enter a new one.

Glad it got sorted.

FWIW, I strongly suspect the problems were caused by having the apps in Dropbox when you submitted them. Locally-stored files are definitely the way to go.

Ok great so revoking the app-specific password will trigger SD Notary to ask for a password?

Not sure if it was dropbox or apple silently fixing something with my account as I have successfully passed other apps this morning that are stored on dropbox. Given your advice I have changed my workflow to run a script that saves an archive copy of my working script to a dropbox folder for disaster recovery but to have the working files on the local drive.

Again thanks for your help.