Switching default script editor

In order to debug a problem with a script link using


I need to temporarily change the default editor on my mac from SD to SE. The only way I know how to do that is to open a ‘Get Info’ page of a script and change the default application there and to apply the changes to all.

However, even after doing this several times, SD still opens when I click a script link (browser = Safari; OS = 10.11.6).

Is there some other setting I should be changing?

Go to Preferences -> General and choose from the Default Script Editor: menu.

… and in SD, go to Preferences -> General and turn off Respond to applescript:// URLs in web pages.

Yeah, I’d done the SE prefs setting, but missed the SD one. Thx!

Oops, that pref setting doesn’t stick. Unset, close SD, launch SD and open prefs: setting is checked again.

Can you reproduce that your end? Might just be a corrupt plist here.

EDIT: no, maybe it’s a bug in SD. Seems you have to uncheck BOTH that one and the one underneath it.

That’s the (rough) equivalent to the SE setting – turning it off sets it to SE. By leaving it on when you leave the page, you’re effectively setting it back. It could probably do with a bit of reorganization.

My experience is that much fiddling with this stuff confuses Launch Services pretty easily.

I hear ya.

Still, that’s a bug in SD. I confirmed it on another machine. If you turn off the first one, but leave the second one on, quit SD then relaunch, the first is rechecked when you open Prefs again.

It would be better if turning off the first one also unchecked the second one; alternatively, the first one could be disabled in the UI unless the second one is unchecked.