Selection Expands When it Shouldn't

I’m stepping through a script and while paused Idecide that I don’t need several lines, so I select those lines and hit the comment button, without stopping the script. I get the alert telling me the script is running, do I want to stop. But, I notice that the number of lines selected in the text has expanded by several.

Also, I’ve noticed that if I try to insert a clipping into paused script, rather than the alert with the option to stop the script, I simply get a beep. Is that intentional? Wouldn’t the alert with the option to stop be better?

Hey, you’re getting a couple of extra characters of selection as bonus for every paragraph you select :wink:

(We’re changing the selection in anticipation of the comment characters being inserted. It will be fixed in the next version.)