SD 7.0.9 + 7.0.10 - Unable to save on server

Since the update of SD to Version 7.0.9 or 7.0.10, i can not longer save an applet on our server per afp or smb. Only bundled-files (app) are affected, single files like ‘scpt’ works fine.

Here i have a screenshot for you.

  1. pic, everytime i compile a script (app), new temporary folder of save state appear.
  2. pic, when i save an applet on an afp-volume.
  3. pic, when i save an applet on an smb-volume (its smb, message show afpAccessDenied).

Confusing is, when i downgrade to prior SD Versions below 7.0.9, the same problem appear. I also removed the preference files but it did not work.

It seems that SD have no permissions to write to the temporarly saved bundle.

There was no change on server side.
When i work from the desktop it is all ok.
I have tested this issue on macOS 10.14.6 and on 10.12.6.

It is hard to find out where the main problem comes from. Maybe macOS, security issues, resource forkes, ScriptDebugger, etc…

Are there any hints or known problems?

Thanks in advance

I don’t think there are any known problems. Can you try with a .scptd file?

I have heard reports of mysterious permissions issues arising, but they’ve all seemed to be solved in equally mysterious ways.

I’ll add that you should check the permissions on all the folders involved, starting with the folder containing your script and on up through to the AFP server volume.

Also make sure that you are logged into the server as the user you expect.

The permissions on server side are ok. Also a test with a compiled script bundle file ‘.scptd’ is ok.
Here are the two examples, please have a closer look:

Is it an enhanced applet or a standard applet? Have you tried saving a new one from scratch?

Hi Shane, it is an standard applet. Same issue at new files from scratch.

And you don’t have code-signing on?

That doesn’t matter if it’s on or off.

Looking at your directory listings, the contents within the temporary folders look okay, but I’m curious about the folder that contains these temporary items and the folder where the script you are trying to save resides.

There are two possible problems:

  1. Script Debugger does not have permission to delete these temporary items
  2. Script Debugger does not have permission to move these temporary items to their final destination, replacing your existing script.