Script template format is getting lost


I used “Save as Template…” to create a script template with the desired formatting. Specifically, with code folding, line numbers, and tab stops showing, but no sidebar pane showing. Then, I set the new template as the one “For New Documents” in preferences.

The .scpt file stored inside the template opens just fine with all the desired formatting. The path is correct, I believe: “~/Library/Application Support/Script Debugger 6/Templates/ASTemplate.sdtemplate/ASTemplate.scpt”.

When I create a new document, the source text from the template is there, but all other formatting is gone. I must be missing a step somewhere. Any suggestions?

Stan C.

Script Debugger draws a distinction between document content (script source, description, etc.) and view settings (window size, wrap lines, etc.). When creating a document, content is drawn from the chosen template and view settings are applied based on the application’s view defaults.

View defaults are altered by configuring a window in the way you want it, and then issuing the Window>Set Default Script Size & State.

There is a boolean expert preference called PrefIgnoreTemplateWindowState which determines if the view settings from the chosen template are to be applied (by default they are not). Please see for a description of all of Script Debugger’s expert preferences and how to alter them.

Thanks, Mark! As always, your explanation is thorough and clear. Now my situation is not only under control, but also right where I want it to be.

Stan C.