Raw AE won't go away

I’m not sure what’s going on here. I have a longish script that mostly controlls InDesign.

The script reopened after a crash (it had been closed and saved before the crash with no issues) and several compiled commands were appearing with the raw appleEvent chevron bracketted code. (See below).

I recompiled the script; decompiled and recompiled. Closed and reopened it; quit and relaunched SD and those raw codes didn’t go away.

I copied and pasted it into a Script Editor document and the raw codes were replaced with the appleScript command.

I pasted the compiled text into SD and it wouldn’t compile. In this case the full name command (that returns a path) isn’t recognized.

tell application "Adobe InDesign 2022"
   tell document 1
      set gridDocName to its name
      set gridDocPath to its «class fnam»
   end tell
end tell

→ Adobe InDesign 2022 17.01
→ Script Debugger 8.0.4 (8A50)
→ MacOS 11.6.2

I can’t reproduce the problem here. Any other app addressed in the script?

I’ve had a few cases where Adobe apps fail to provide their scripting meta-data correctly, resulting in exactly this problem. Usually, quitting and re-launching all the Adobe apps and Script Debugger is enough to clear this situation.

Just BBEdit.

Quitting ID and SD together then relaunching SD worked. (Although, when I had tried quitting just ID, Photoshop and Illustrator were both running. This time neither was, so it may have been quitting all Adobe apps that made a difference. Still don’t understand why it would work in SE but not SD.

It could be that the application caches that is corrupted and thats why you see it in 1 application and not other.

Sometimes the solution is:

  1. Restart the applications
  2. Delete the application caches
  3. Reboot
  4. Make a new user account if above do not work

I have tracking the ~/Library/Caches folder and when a application is started it make update or new files. If this files are corrupted I guess it could effect the performance of the target application.

Quitting the Adobe apps is less disruptive than all that, but if that doesn’t work, that’s what I’ll try, thanks!

So, at this point, I’m not so much asking for help for the issue, but reporting the issue to Mark and Shane.

When this happens again, guys, is there any additional information you may need, like a sample or something?

I suspect that by the time you see it, it’s too late for a useful sample.