Open Quickly bug


You video works now. That was one messy window :slight_smile:


Yup, it was messy. I think it leaves the system in a slightly unstable state too. On both systems (home and work) I’ve noticed windows appearing blank, or black for a second before displaying correctly, and in general opening and closing windows seems to take longer. Rebooting the mac helps, until I try using Open Quickly again.

Anything more you need on this Mark?

Noticed there was a Mac OS update available. Same behavior after update.

–> Script Debugger 7.0 (7A25)
–> Script Debugger 6.0.7 (6A217)
–> Mac OS 10.11.6 (15G19009)

Mark and Shane,

Open Quickly crashed while I was using it. I got 3 different crash reports for the crash. All 3 reports were zipped into an archive called “Reports for SD” and I uploaded the archive. The 3 reports are:

  • Crash report from script debugger
  • Crash report from “User Reports” in Console
  • Apple Crash log from copying info from crash report dialog

What I did to get the crash was match exactly the same input Ed entered while watching the video he posted. I go through the process once with no errors. On the second try I went to the “File” menu and chose “Open Quickly” and typed “for” and as soon as I clicked the “Open” button it crashed.

On Ed’s Mac there were 359 files found while on my Mac there were 1563 found files that took about 20 seconds to find. After the 20 seconds the spinning gear in the bottom right of the “Open Quickly” window on my Mac stopped spinning. On Ed’s computer computer the spinning gear never stopped spinning. I have a late 2015 iMac with 16 gigabytes of memory. I don’t know what Ed’s Mac is but the difference could account for the speed differences.

I’ll see what else I can figure out about the problem.

Reports for SD (55.0 KB)

1 Like

Mark and Shane,

I forgot to get the console output for the crash in my previous crash report. It looks like there is some useful information in there. I did the entire test over again. Again I followed Ed’s exact steps and it crash again, this time on the first try. Right after (a second or two) I finished typing “for” it crashed. In my previous report I said it crashed after clicking the “Open” button. But now that I think about it I think I was moving the mouse to the button but it crashed just before I clicked the button.

But as I said it looked like the console report might have some useful stuff. It reported an error “dynamic accessors failed to find @property implementation for ‘uniqueId’” for both the “ABCDInfo” and “ABCDContact” while resolving selector ‘uniqueId’.

It got 5 errors when dynamic accessors failed to find @property implementations for ‘uniqueId’, ‘orderingIndex’, ‘address’, ‘label’ and ‘isPrimary’. It got a couple of errors at the end of the console output but I don’t they are as important. I think they are more the effect of an error then a cause of a problem.

I included 3 files in this report:

  • Script debugger crash report
  • Apple crash report
  • Console output

I zipped the 3 files into an archive called “Reports for SD crash # 2”

Reports for SD crash # (55.6 KB)

Cool, thanks for making the effort to reproduce and gathering all the details.

Which Mac OS version you’re using?

In my tests I was actually trying to type the word “forum” but the hang starts after two or three letters (and I’m a fast types).

Also it doesn’t seem to matter what term your searching for.

I tried and tried with 7A26 and I couldn’t make it crash

Thanks! (Open Quickly has become one of my favorite features)

–> Script Debugger 7.0 (7A26)
–> Mac OS 10.11.6 (15G1611)


If I hadn’t had you video I might not have made it crash. Originally I tried it but I entered text and immediately hit the button. It didn’t crash. But when I was doing things at the speed you did things I can barely get it to work without crashing. I watched your video while testing and I did things at the same time you did.

I am running 10.12.6 Sierra. It could well be that the problem is worse under Sierra, it errors differently under Sierra, or it’s worse on the particular Mac I using, … that was why I wanted to see your video. The stuff I sent Mark has some specifics in it that will probably help Mark track it down or at least give him a lot better idea about what is causing the problem.

Thanks for the video.


1 Like

Seems to have been fixed on 10.11, how about 10.12?

Shane and Mark,

I ran the “Open Quickly” test with the new Script Debugger 7.0 (7A26) and it crashed the first time I used it. But the error was different and the error behavior did change from the previous test I did.

I included the following error files in a zip archive called “Reports for SD crash #”

  • Console output.txt
  • Apple crash report.txt
  • Script debugger crash report.txt

This time when I typed “for” and waited nothing happened, no crash. After a while I hit the return key and it crashed immediately. I will have to try the test repeatedly to see if I can still get original error of just typing in “for” and waiting for it to crash.

This time none of the console lines had errors, they are all default lines.

Reports for SD crash # (51.2 KB)

So I followed Bill’s instructions and I’m not getting a crash but am getting odd behavior. When I hit return it seemed to hang for a few seconds then opened the selected script.

But now the SD7 window is whacked. (Not quite as bad as before. I can’t close tabs. I can’t close the window. But, after a while the tabs I tried to close just closed.

To summarize, It seems that there are three problems:

  • the crash Bill is experiencing (I have a fix in hand for build 7A27)
  • the hang Ed is experiencing while the Open Quickly panel populates (I cannot reproduce this)
  • the corruption of windows when opening scrips Ed is experiencing (I cannot reproduce this)


I tried to test out “Open Quickly” with SD7 (7A27) but “Open Quickly” is grayed out and I can’t figure out how to get it to work. Is there some special condition that keeps it from working, or some special condition that has to be true before it will work?



It looks as though SD has switched into Lite mode. When you launched it, did it present an alert telling you the demo period had expired? Pressing the Continue button will put you in lite mode.

This is separate from the fact that your SD6 registration number should be working. I’ve probably messed something up at my end. Let me take a look.


I didn’t see any indication I was in lite mode. I certainly started out out in SD7 mode.

It did tell me my trial was up. I hit the continue button it and it kept going. Does that take me into lite mode? I was doing things that aren’t available in lite mode?

Here is a picture of the about box.




How can I use all the pay-only stuff if it is in Free Lite Mode? I’m confused.


Click the Enter License button and enter your Script Debugger 6 registration number. For some reason, this information got erased and SD reverted to Lite mode.


I meant to get back to you earlier but I wasn’t up to working on the Mac for a few days.

I’m pretty sure I caused the SD7 registration to get lost. I mentioned a while ago about removing all the files that went with SD7 from the system folder to see if the problems I was having would go away. See the following link for the post that was in.

The idea was to put those files back into the system folder after the test. Unfortunately I forgot to do that. I have also lost the files that should have went back in. So I am continuing with the files I have in the system folder since they are the files SD7 installed. I reentered my SD6 serial number. I listed the files I removed from the system folder at the end of this post so you can see exactly what I did.

I am assuming this is what killed my registration data. Removing the files happened before the dialog came up and asked me to enter my serial number of to click continue. That must have started the free trial period which ended abruptly and put me into “Lite Mode.”

Do you agree this satisfactory explains the lost of the registration information? If so I will proceed on with my other testing.

The files I removed from the system folder
Application Support

  • “Script Debugger 4.5” folder
  • “Script Debugger 5” folder
  • “Script Debugger 6” folder
  • “Script Debugger 7” folder
  • “Script Debugger Lite 6” folder


  • “com.latenightsw.ScriptDebugger6” folder
  • “com.latenightsw.ScriptDebugger7” folder


  • com.latenightsw.ScriptDebugger.LSSharedFileList.plist
  • com.latenightsw.ScriptDebugger.LSSharedFileList.plist.lockfile
  • com.latenightsw.ScriptDebugger.plist
  • com.latenightsw.ScriptDebugger.plist.lockfile
  • com.latenightsw.ScriptDebugger5.LSSharedFileList.plist
  • com.latenightsw.ScriptDebugger5.LSSharedFileList.plist.lockfile
  • com.latenightsw.ScriptDebugger5.plist
  • com.latenightsw.ScriptDebugger5.plist.61y6lIh
  • com.latenightsw.ScriptDebugger5.plist.aLXqt67
  • com.latenightsw.ScriptDebugger5.plist.CRUmbpJ
  • com.latenightsw.ScriptDebugger5.plist.KzSJLTn
  • com.latenightsw.ScriptDebugger5.plist.LkffReF
  • com.latenightsw.ScriptDebugger5.plist.lockfile
  • com.latenightsw.ScriptDebugger5.plist.lTQQbmK
  • com.latenightsw.ScriptDebugger5.plist.lVdfh0v
  • com.latenightsw.ScriptDebugger5.plist.MMKPMq0
  • com.latenightsw.ScriptDebugger5.plist.PMJZg7b
  • com.latenightsw.ScriptDebugger5.plist.qU78Zbk
  • com.latenightsw.ScriptDebugger6.LSSharedFileList.plist
  • com.latenightsw.ScriptDebugger6.plist
  • com.latenightsw.ScriptDebugger6.plist.5ytsKIi
  • com.latenightsw.ScriptDebugger6.plist.LMJDIvY
  • com.latenightsw.ScriptDebugger6Lite.plist
  • com.latenightsw.ScriptDebugger7.plist

Bill Kopp

Haven’t been able to reproduce the bug. And I tried and tried.