Open Quickly bug

I’m trying to open a droplet saved with debugging on. First I have to find it so I use Open Quickly.

When the search results are displayed I double-click on the droplet and nothing happens.

I try Open Quickly again, double click on the droplet and a buggy window opens with no controls, mostly blank with lots of artifacts. Can’t get rid of it and have to quit SD7.

Relaunch the first time and there’s a bug reporter window.

Relaunch the second time, and no bug report.

Also, when I tried the second time, a script opened behind the buggy window, but it wasn’t the script I was trying to open and wasn’t a script that appeared in the Open Quickly result list. That same script reopened when SD7 relaunched. It’s a script I’d worked on a few days ago.

Anyone else having issues with open quickly?

–> Script Debugger 7.0 (7A25)
–> Mac OS 10.11.6 (15G1611)

Also, speaking of Open Quickly, there is one thing about it that bothers me.

It seems to jump into its search too quickly. I’m a fast typist, but it seems I can’t type more than two or three letters before it starts searching and hangs.

At least give me a full second after the last keystroke before starting the search.

Not sure how to approach turning this into a test case. If you can make it happen again, perhaps take a screenshot or capture a movie so we can see what you are seeing. Also, please see if anything relating to Script Debugger was written to the console log at the time when the problem happened to you.

Here is a quick attempt at reproducing the problem here which works successfully:

So I’m on my home system and I tried again and got a similar result.

I then quit SD and tried again (while doing a screen recording) and it worked. I tried three more times (without recording) and on the third time it happened again. Here’s a screen shot.

I’m not that familiar with using console, so I’m not sure what info you want there. The big black window behind console is the SD’s buggy window that I’ll have to quit, maybe force quit, to get rid of.

–> Script Debugger 7.0 (7A25)
–> Script Debugger 6.0.7 (6A217)
–> Mac OS 10.11.6 (15G17023)

And it happened again, this time during a screen recording

Quicktime movie link: OpenQuicklyBug

Another Open Quickly problem.

This time I selected it from the window, typed a word with five letters (forum) and typed it pretty quickly. It hung after the second letter. I let it spin for a few minutes then came back and it showed a long list of files with “fo”

SD was still hung. Had to force quit.

Tried again, very similar outcome.

Basically Open Quickly is unusable at this point. Crashes or hangs 100% of the time.
–> Script Debugger 7.0 (7A25)
–> Mac OS 10.11.6 (15G17023)

Open quickly works just fine on SD6. I can even finish typing my search term, and open found files without crashing or hanging

–> Script Debugger 7.0 (7A25)
–> Script Debugger 6.0.7 (6A217)
–> Mac OS 10.11.6 (15G17023)

I’m not seeing crash reports from you relating to Open Quickly here. If it crashes, please include the crash report here. If it hangs, please use Activity Monitor to get a Sample report. I need somewhere to start tracing the cause of these problems.

Note that I have received a couple of crash reports from you for code signing issues that occur while operating the save panel. These are fixed and will appear in the next build.

Note that I have received a couple of crash reports from you for code signing issues that occur while operating the save panel. These are fixed and will appear in the next build.

WTF? I have not had any issues with saving at all, and no crashes or hangs while operating the save panel, and have never learned anything about code signing, much less tried to use it.

Just tried this at work. Here’s a screen shot of this particular hang. Rather than the spinning rainbow cursor hang, this hang is the spinning time waster to the left of the Cancel and Open buttons. (what are the proper names for those?)

As you can see in the screen shot I started typing the word “forum” typing quickly, but only the first two letters appeared and then it hung. I’ll have to force quit now.

Here’s the link to the AM sample:

–> Script Debugger 7.0 (7A25)
–> Mac OS 10.11.6 (15G1611)

I’m not seeing crash reports from you relating to Open Quickly here.

Also I’m not getting crash reports when I have to force quit after these Open Quickly hangs.

I do get crash reports nearly every time I open SD6, even though it didn’t crash or I didn’t think it crashed the last time I used it. I usually quit. Sometimes it blinks right out, and I always get a Crash Report window. Sometimes it takes the normal pause as it gracefully quits or whatever, and I still get a crash report window.

Can you confirm that the reports you’re referring to are from SD6 or 7?

(Even so, no crashes while saving, and still no messing with code signing ever).

Thank you for the sample report. Unfortunately, in this instance it does not give any clues. Script Debugger appears to be idle, waiting for UI events. The fact that SD appears hung from your perspective is puzzling.

Please send a couple more Sample reports. My hope is that one of them will catch SD in a state where there is some clue to what is causing the hang.

FWIW, here’s a movie of the unstable state SD is left in after this hang. This movie shows what I see. Blank dialogs, blank screens, no response to clicks.

On the second blank dialog I hit cmd-d (Don’t Save) and after several seconds the window closes.

I was able to quit SD after this, rather than force quit, and no crash report came up.

The previous sample was taken after giving sd a few moments to clear. I’ll take the next sample as soon as it happens.

Quicktime link: BehaviorAfterOQHang

Yes, each crash report I receive caries the SD’s bundle ID, version and build number. From this information, I can distinguish SD7 and SD6 crashes.

I received one SD6 crash report from you today (crash while dragging a tab)
I received another SD6 crash report yesterday (SD failed determining if you have any code signing identities)

Hmmm, the one from dragging a tab may have happened yesterday, and I didn’t relaunch.

The fact that I haven’t ever done anything with code signing might account for me not having code signing identities? Should that cause a crash on quit?

New sample, a few seconds after the hang.

I was able to close this open quickly window after the sample was taken. I clicked cancel, and about 10 to 15 seconds later it closed. Opening a new script window resulted in a buggy window

No, it should not. Its an SD bug that we’ve fixed for future builds.

Had a few minutes so I decided to try again. Did its thing on the first try. No crash reporter on restart.

Here’s the sample link:

And here’s the screen movie link:


I should note that this latest version came shortly after a Mac reboot.