Notary Issue Signing

I have been able to save Enhanced Apps with another app bundled into a “bin” folder I created in resources in the past. It no longer works. Gives me error that its Run only and permissions can’t be changed and if not Saved as Run only I get the same error.

19:25:25.805: Error 105553134527488 in xattr: xattr: [Errno 13] Permission denied: …A possible cause is that one or more files with extended attributes also have their permissions set to read-only.

How can I include an App in the resource folder? I can’t add it after notarizing unless there’s a safe folder I can do that with.

I found a temporary fix. Seems like a bug when Script Debugger exports an enhanced app, it makes the script inside of the apps resource read only so it can’t clear the extended attributes. I changed the Resource folders contents to read/write for my user account on the enclosed .app file and it was able to Notarize.

It’s a tricky problem, because normally the script file needs to eb read-only to avoid accidentally corrupting the signed app bundle. The best approach, where possible, is probably to notarize the apps and put them in a .zip file, to be unzipped to somewhere when needed.

Last year you updated the Notary app to solve an issue with being unable to sign with Enhanced app reporting a similar error. I think it was because there were script bundles exported run only. You resolved this in the last update very quickly. Is it possible whatever you did to resolve could be applied to .apps?

Oddly enough the only way I can get my enhanced app notarized is by:

  1. Save outside of Enhanced App. (can’t export run only or notarize in step 4 fails)
  2. Exporting the Enhanced App without but can have shell scripts or scripts and bundles even if exported run only.
  3. Before Notarizing move the which cannot be a run only app
  4. Notorize Enhanced App.

Do you know why I can have Script bundles run only but not the App? The error reports the script inside of resources/scripts permissions being read only as the issue. Since both bundles and apps have same structure it doesn’t make sense to me why the issue.

Basically I have a Enhanced menu bar app that triggers scripts, prefs etc.
I can have run only script bundles in the /Scripts folder when exporting but not apps saved by SD in any form.
I created a “Helper” app that I want inside the Enhanced app anywhere inside resources. When a user clicks on a link on a private web page it triggers a script inside the Menu bar app via tell "menubarapp" to do whatever. I prefer this method rather than 2 apps. I see other non SD developers bundling app inside apps.

Option 2 is to try to make the menubar app respond instead of the Eliminating the need for it. When I attempted this, adding on open location this_URL to the menubar app, when clicking on the link, it tried opening the app again instead of the open location running inside the running app. Does anyone have a suggestion on how the menu bar app can be triggered by a link when it’s already open? Maybe I am missing something that could be done differently.

Your request has been noted. As I said, it’s a tricky problem, and my concern is not to cause others problems for what is a pretty rare case.

1 Like