Not compiling when saving


Sometimes when I have been working a script for a while and I do a save SD7 does the save but does not visibly compile the script. It stays the way it looks after a change has been made but before the compile button is clicked. Also this problem is window specific.

The script keeps running normally when in this state after I fix the syntax error. If I click run the syntax error is found. It looks like the syntax check is not being performed when I save. I added a syntax error to the script, pressed command-s and it save without the new text changing in any way in the script window and it saved with no errors. When I reopened the the script the syntax error was still in the script. Also when I opened the script it came as uncompiled, i.e. all of the script had the font set for uncompiled text.

However after I open the script with the problem and click the compile button it has no trouble finding the syntax error.

I quit Script Debugger and double clicked the problem file and it came up with a crash report. Nothing came up at that time in the console. No Apple crash report came up. This same file opened in SD7 before restarting SD7 with no problems except for the compile issues. It looks like whatever was failing before did recognize the file was messed up after relaunching SD7.

I have been trying to get something definitive on this error but I guess what I’ve told you is as good as it gets. I’ve tried for a little over a day and all I have is a vague report. For some reason today was the first time I tried opening the file saved while the problem was occurring. It’s not much to go on with a corrupted file and a crash report from opening the file but it’s the best I’ve got.

Do you have any suggestions as to how to track this down better. Right now if I work on the same file for a long time (many hours) about a quarter of the time it has this problem.

I included the crash report in this post. I have also included the problem script file. I zipped the file to try and keep the state of the file preserved. When the problem first occurred the debugger was turned on and the debugger was still on when I saved the file.


8 (203.6 KB)

SD crash (32.1 KB)

If you document is a text (.applescript) file, then SD will not compile on save. SD operates this way so that you can save a script as a text file with a compilation error. Any other file format requires a successful compile in order to save.


There are a number of weird things here. I up loaded the wrong script file. I enclosed the script file ( I had meant to send. It was a compiled script. I had meant to create a “compiled script bundle.” I don’t remember creating “8 copy.applescript” but it is still on my disk so apparently I did. I uploaded the compiled file that was giving me troubles in case you wanted to see the script file that went with the problem.

I tried to save the file with the syntax error “set h tp 4” but SD wouldn’t let me save it. Somehow I got a AppleScript text file created and that allowed me to save the error. Sorry about that. (12.1 KB)