Nasty reproducible bug

I have a standard AppleScript droplet that I’ve been working on. After making some minor changes I looked in the resources tab, and changed a couple settings (version/build/turned on increment on save).

Then I noticed the field for accept files with these extensions. I was surprised it was there because it was not an enhanced applet.

I entered two extensions (txt TXT) but then I couldn’t do anything. Couldn’t edit the script couldn’t close the script. If I selected text in the script it wasn’t actually selected.

I tried to save using the file menu and SD became unresponsive and had to force quit.

When I relaunched the script reopened and the last changes I’d made were lost (that’s the nasty part).

Opened the resources tab again, and entered the same two extensions and got the same result.

Same behavior at in the office. It seems that entering the extensions causes the issue.

–> Script Debugger 7.0.3 (7A55)
–> Mac OS 10.11.6 (15G20015)

(I believe these are the same at home and office)

Thanks for the report. One point, though:

Those fields apply to standard droplets too.

Any chance of seeing the applet? I can’t reproduce the problem here.

This is the applet with all the handlers but the open handler removed.

I left in all the use statements an properties.

I probably should have mentioned it’s in debugging mode. I think that makes a difference

OK, I can reproduce it here, thanks.