Links to videos

That’s odd. Twice now I’ve linked to videos stored and shared on Dropbox.

They used to work yahoo groups, but I don’t think they work here.

Here’s one:

OMM I see the control strip that would be at the bottom at the bottom of the window, but no video, so it’s trying to do something. It says “Loading…”

This one uses the hyperlink button for the forum.

Am I missing something?

Do these work for anyone else?

Other links to dropbox seem to work.


None of the videos worked, but the link worked great.


As you describe, I see the control bar but the video its self never loads. I wonder if this is a deliberate DropBox thing. Having people host public videos from DropBox may represent a bandwidth issue for them. It could also be Discourse (our forum software) which provides the video viewer. Do the videos work if you embed them in a normal wed page? If they do, then that suggests an incompatibility between Discourse and DropBox.

I believe so.

Contrast this link, which I created using a script rather than getting it from the Dropbox software:→%20Show%20→%20Action.mp4

  • I will delete that vid eventually, but for now you can see it is available in the forum.


I think it’s a Discourse thing. I can right click on the control bar and select “Copy Video Address” and paste that into a new window at it works just fine.

I wonder if any other discourse forums have a similar issue with Dropbox videos

I’ve been doing this for some time without any issues.
Here’s a SD6 video hosted in DropBox that runs fine when I put the URL in a Chrome browser.

See if this works for you.

How are you generating the URL for the link?

After I save the movie I go to the DropBox menu and select “Copy Link.” this gives you a link, with the “s” for sharing.

Seems that discourse is the only place that doesn’t work.

Here’s the link without the https:// at the start.

Hey Ed,

You’ll have to get a public link from your Dropbox account ONLINE (not local) to supply the URL prefix for the “dbBaseURL” variable in the script.


# Auth: Christopher Stone
# dCre: 2013/04/29 23:22
# dMod: 2016/12/14 18:55
# Appl: Finder & Script-Runner
# Task: Copy Public Dropbox URLs from selected files to the Clipboard.
# Libs: None
# Tags: @Applescript, @Dropbox, @Public, @URL, @Clipboard
# Test: Mavericks, Yosemite, El Capitan

   # User must supply by going to their account online and copying a public link:
   set dbBaseURL to ""
   set dbPubStr to ((path to home folder as text) & "Dropbox:Public:")
   set AppleScript's text item delimiters to "/Dropbox/Public/"
   tell application "Finder"
      set _sel to selection as alias list
      if _sel ≠ {} then
         set hfsPath to item 1 of _sel as text
         if (hfsPath does not contain dbPubStr) or (hfsPath = dbPubStr) then
            error "Selection not in Public Dropbox folder."
         end if
         repeat with i in _sel
            set contents of i to (dbBaseURL & (text item 2 of (get i's URL)))
         end repeat
         set _sel to joinList(_sel, linefeed) of me & linefeed
         set the clipboard to _sel
      end if
   end tell
on error e number n
   stdErr(e, n, true, true) of me
end try

on joinList(_list, _delimiter)
   set {oldTIDS, AppleScript's text item delimiters} to {AppleScript's text item delimiters, _delimiter}
   set joinedList to _list as string
   set AppleScript's text item delimiters to oldTIDS
   return joinedList
end joinList
on stdErr(e, n, beepFlag, ddFlag)
   set e to e & return & return & "Num: " & n
   if beepFlag = true then
   end if
   if ddFlag = true then
      tell me
         set dDlg to display dialog e with title "ERROR!" buttons {"Cancel", "Copy", "OK"} default button "OK"
      end tell
      if button returned of dDlg = "Copy" then set the clipboard to e
      return e
   end if
end stdErr

Thanks Chris, I will try this as a workaround (hopefully temporary).

Opening a browser, copying a link and running a script as opposed to a single menu selection. It would be better if Discourse could simply display a perfectly good link to a video.

Ed, if you are asking me, the answer is:

  1. Show file in Finder

  2. Right-click on file, and select “Copy Public Link”

  3. Paste that link into the forum post.

Has worked every time for me without exception.

Hey Ed,

You only have to get the public prefix ONCE and add it to the script.

I don’t use Dropbox’s Finder extension, because I’ve found it buggy – and I only run Dropbox when I need to update files.

My script is bound to a keyboard shortcut in FastScripts, so I don’t have to mess with it.

Select a file or files.

Hit a keyboard shortcut.

Paste the link(s) where I want them.



Got it. For me, the bottom line is this.

This is a discourse bug, not a dropbox bug.

Dropbox generates a perfectly serviceable URL that works pretty much everywhere to display videos except in the discourse forum. This is the only place I know of that’s had this issue.

Discourse recognizes the URL as a video, tries to display it as a video but doesn’t display.

I’m just suggesting that someone report the bug to discourse and see if they are aware of it and if they have workarounds.

In the meantime when I need to post links to movies from DropBox I’ll try one of the other methods, none of which are as elegant or efficient as Dropbox method that doesn’t work here.

To illustrate, here’s a movie of saving a movie to DropBox and getting the link:

The second link is the url - the https:// and that works.


Clicking a link isn’t that bad. I tried it and it worked fine with no problems. I could see the video and hear the sound. It gets the job done. You just don’t get a nice pretty picture in a box before you you watch the video. For me a link is perfectly acceptable.


That’s an acceptable workaround until Discourse can fix the issue.

If I were a discourse customer I would report the issue. (I will report it to Dropbox, but it’s not their issue.)

I’m not sure that is entirely correct.
I am able to consistently post videos in DropBox to Discourse forums (here and Keyboard Maestro). I showed you my process above, and posted an example video above. I’ve never had a failure.

Perhaps one difference is that I have a top level DropBox folder called “Public”, and I have set the Dropbox permissions for “Everyone ReadOnly”.

The style URL is designed to bypass all issues with permissions. It can share any file you specify from your dropbox folder. (It doesn’t have to be in the public folder. )

Using that link format I can, for example, keep all my SD debugging movies and files in a private folder, but share individual items and the only people who can see the items are those who have the links.

That style link works everywhere else in nearly every other context. (In one forum I go to they only display and play youtube videos in posts, so with the dropbox link they just show the URL. I’ve put in a request there to display and play videos from other sources).

It even works in discourse as a link; as opposed to a video link. Discourse attempts to load and display the link and fails. It also works in discourse to show nearly every other kind of file (the exception being AppleScript apps, which it treats as folders).

I know Dropbox doesn’t have the best rep, but that doesn’t mean that we can just assume that any problem with a link is a dropbox problem.

There are other ways of inserting dropbox videos into posts (none as simple to use or as good as this method), but this is still a bug that should be fixed.

Here’s the message I would send to Discourse:

"There is a bug with displaying videos from Dropbox using the format. That is the format dropbox uses for sharing specific files, and it works in Discourse for all other kinds of files. For video files rather than display the video in the posts with the option to play within the post, Discourse only displays the video’s control bar.

Is this an issue with the set-up of the forum or is it an issue with Discourse displaying videos using the style link?"

This is the post I made on the Dropbox forum.

Hi, When I post a link to a dropbox video in a Discourse forum the video image appears in the post and it will play in the post. But, if I use the “” style link to the video it doesn’t display and play in the post.

Instead the video control bar appears and nothing happens.

Is this a known issue with Discourse and the style of sharing videos?

This is the discourse thread. The one team member seems to know what the issue is (blames dropbox, but provides what I think is an implementable workaround.)

OK, one more thing. Apparently if I change the 0 at the end of the URL to a 1 it works.

Ed, I’m glad you figured out a solution.

Looks like DropBox is changing their policy/service over the next year.
I just got this email:

From: Dropbox
Date: Thu, Dec 15, 2016 at 8:00 PM
Subject: Your Public folder will soon become a private folder

We’re always looking to improve the Dropbox sharing experience. The Public folder was the first sharing method we introduced, and since then, we’ve built even better ways for you to share securely and work together with your team.

As a result, we’ll soon be ending support for the Public folder. Dropbox Pro users will be able to use the Public folder until September 1, 2017. After that date the files in your Public folder will become private, and links to these files will be deactivated. Your files will remain safe in Dropbox.

If you’d like to keep sharing files in your Public folder, you can create new shared links. Just make sure to send the new URLs to your collaborators.

In addition to shared links, we have a number of sharing options designed to make collaboration easier and give you more control. To learn more, visit our Help Center.

Here’s their new process for sharing:
Give people view-only access to your files