How to deploy a notarized .app created with SD Notary

I am wanting to distribute an app on the Mac so I recently became an Apple Developer so I could code sign my application and get it notarized. I am using the app SD Notary to notarize my .app file.

The notarization process completes successfully

The app runs fine on my Mac. However, I am not clear on how to take my notarized .app file and distribute it. I suppose I would like to put it in a simple .dmg file where the user is presented with a disk image Finder window that allows them to drag/drop the .app file into their Applications folder.

So far, I’ve tried testing the app on other computers by putting it in a .zip file (by right clicking the .app file in the Finder and choosing Compress). When I do this I get the error “New Video Job” can’t be opened because the idenity of the developer cannot be confirmed.

I also get this error if I eMail the .zip file to myself and try running the .app file after opening the .zip file

Is there another step I am misunderstanding in terms of needing to also notarize the container that I put my notarized .app file in? I also tried compressing a non-notarized version of my .app file and then using SD Notary to notarize the .zip file but SD Notary would not accept the .zip file.

I’ve read a number of support articles and forum posts and I’m not quite connecting all the dots. That said, I am very confused and would greatly appreciate any direction/guidance you can provide.

Thank You in advance,

Ben Brodbeck

Once you notarize an app, you should be able to zip it and distribute it (disk images require extra work). I’m not sure what’s happening with your app, but I’d like to have a look at it.

1 Like

For anyone following along, Ben sent me the file and the issue was that among the files in the Resources folder was a symbolic link pointing outside the bundle.

If you have an app that notarizes OK but still doesn’t behave correctly, it’s worth checcking it with spctl in Terminal:

spctl -vvv --assess --type exec /path/to/

In this case, the result was:

/path/to/ rejected (invalid destination for symbolic link in bundle)

which was the clue needed.


Thanks for taking a look at this and for the great feedback. Changing the symbolic link destination to a path within my application bundle solved my issue.

I’m very grateful for your willingness to help. This saved me many hours of frustration. If we ever meet in person, beers on me.

Ben Brodbeck