How not to start the debugger automatically when a script is run

how-to

(Emmanuel Jaep) #1

Hi,

I’m a complete beginner with the script debugger, so please be forgiving if it is an obvious question.
I just created a script that I use to manipulate outlook messages. In order to use it, I saved into the outlook folder and display the Script menu in the menu bar.
I also had another script (edited with the script editor) in the same folder.

When I run the script written with script debugger, a new instance of script debugger is launched and I have to click on “run”.
When I run the script written with the script editor, the script is simply run.

My question is the following: Is there a way to save the script from script debugger in such a way it doesn’t open in script debugger every time I run it?

Thanks in advance for your help,

Emmanuel


(Ed Stockly) #2

Welcome to the fun!

The answer to your question is yes. Before your save your script take it out of debugging mode.

Script Debugger has a great feature that allows you to debug scripts in the context from which they are called. When they are saved with debugging on and then launched from, for example, a script menu, the script opens in Script Debugger, allowing you to step through it live. To avoid this, turn off debugging mode before saving.

You can do that from the Script menu>Enable Debugging. Also, unless you’ve customized the toolbar layout there should be a debugging button that lets you toggle debugging on and off.

HTH


(Emmanuel Jaep) #3

That’s brilliant. Thank you!


(Sean Murphy) #4

Script Debugger also defaults to prompt the user to run the application. When saving an app/script in the save window there is a check box for “Show Startup Screen”. Uncheck this if you don’t want the “Do you want to run this application” dialog to pop up when running.

It can also be modified via this menu:
File > Application Options > Show Startup Screen

Not sure if there is a way to have this unchecked by default. I have never wanted to use that startup screen or have any of my users bothered with that either.


(Shane Stanley) #5

It’s recorded along with all your other document-level settings when you choose Window -> Set Default Script Size & State.


(Sean Murphy) #6

That doesn’t seem to work for me.


(Shane Stanley) #7

It should work with any new documents you create.


(Sean Murphy) #8

Yeah, it is not persisting for me after setting default script size & state. I have tried several different ways (create new and save with settings, default s s & s, quit, open new, etc). All new are still creating with Show Startup as checked.


(Shane Stanley) #9

My mistake – let me check why it’s not happening.