Help! Some problems about Myriad Tables Lib


#1

I have the Dialog Toolkit.scptd and Myriad Tables Lib.scptd stored in ~/Library/Script Libraries

"Dialog Toolkit” works just great. The script runs OK when I include the code “use script “Dialog Toolkit” version “2.0"”

But every time I try to tun sample scripts which include the code “use script “Myriad Tables Lib” version "1.0.8””, it gives error information like this:

“missing value” does not understand information of “localizedDescription”
-1,708

Does this problem occur to anyone before?
Does anyone who happens to know how to fix the problem?

Many thanks.


(Shane Stanley) #2

The first thing to try is to download a new copy of Myriad Tables Lib.scptd and replace the old one.

You’re not using DropBox with ~/Library/Script Libraries by any chance?


#4

Thanks for replaying.
I downloaded the scptd from macosxautomation.com recently. Is the latest version 1.0.8?
And I am not using DropBox or any other similar application with ~/Library/Script Libraries. I created the folder and put both Myriad Tables and Dialog Toolkit in the folder. The Dialog Toolkit just works but Myriad Table doesn’t.
By the way, what does the error code -1,708 mean? The Script Debugger shows me the error code.
Thank you!


#5

This is the information error given by Debugger.
By the way, I’m using OS X 10.11 El Capitan, AppleScript 2.5


(Ed Stockly) #6

Version 1.0.8 is the version I have installed, and I’ve not had any issue like that.


#7

I’m trying to figure out what does localizedDescription mean and what does error -1,708 mean?
Maybe the problem arises because I don’t have some components installed on my mac?


#8

Can you tell me what OS version you are using?
Thanks.


(Shane Stanley) #9

When there’s an error in a Cocoa framework, the localizedDescription method is used to get an explanatory string to display to the user. It’s failing here because the error itself is empty.

Unfortunately that doesn’t make what’s going on any clearer.

I’m wondering if it’s possibly an issue related to non-Roman or non-English systems. Can you try it using English as a test?


(Ed Stockly) #10

–> Script Debugger 7.0.5 (7A62)

–> Mac OS 10.11.6 (15G22010)


#11

Problem solved.:joy:

My default script application is Script Debugger. When I tried to run script with myriad table codes in script editor(the default one in mac), the script runs OK and shows me a table.

Then I changed to script debugger to run the same script, it also shows me the table.

It’s really strange. Maybe that’s something related with my non-English version. And when it is run by script editor, the characters are properly recognized. Now I can get the final result.

Anyway. Thank you!