Fetch drops Applescript support

Fetch is a very long-lived, full-featured Mac app for handling FTP, SFTP, and FTPS file transfers, featuring Bonjour support, auto-resume, droplets, Quick Look previews, folder sync, one-click editing of remote files, and more. The latest version is based on 64-bit code for compatibility with macOS Catalina while dropping AppleScript and Automator support.


Thanks for the heads-up on this. This is indeed sad news.

I know nothing of their plans, but I wonder if this is a consequence of their having to move an old code base to newer APIs in order to gain 64bit support. It may just be that they didn’t have time to complete the AppleScript/Automator code to hit their release date.

I’m sure if their customers let them know AppleScript is a critical element of their software, they may consider bringing it back in the future.

I wouldn’t hold any breath.

When Rogue Amoeba moved from Audio Hijack Pro (v2) to Audio Hijack (v3) they dropped AppleScript support and later said they were considering bringing it back.

I think that was 4 years ago now.

There‘s literally no AppleScript support, not even for starting to stopping a session.

From what I’ve read, AppleScript wasn’t actually dropped. I’m sure it was challenging enough just to migrate to Mac OS 10.15. I believed due to time constraints, AS support was just delayed to later updates. Beta tester communications and post to the developer’s website stated AppleScript support and other delayed features would be added in future updates.

I did some beta testing and it worked great. I’m just grateful that there is longtime Mac developer making a solid SFTP app—but I do look forward to AS support being added.


This is half off-topic, half about AppleScript, so here goes.

Fetch, like Transmit and every other Catalina-compatible SFTP client that I’ve tried does NOT have the ability to send unix commands (like echo>filename) over SFTP. (Transmit says it has the feature, but it simply doesn’t work, as they acknowledged when I asked.) The only Mac client that has it is Yummy FTP Pro; but the developer died unexpectedly and it will never be Catalina-compatible.

AppleScript to the rescue. I threw together an applet that sends a command to the server and checks for a successful result.

Rob D, if you’re in contact with the Fetch developers, or if you have a contact name, I’d like to request that feature.

And apologies for OT bandwidth-wasting.

After posting this, I asked the Fetch developer about sending SFTP commands and also about AppleScript. He says he’s definitely bringing back AppleScript support.

1 Like