Expiring build (5-2022)

Two things, on launch I got a message that the build was expiring in four days (May 1). It gave me the option to check for a new build.

Checking for a new build stalled out and I got an error message. I tried again from the Script Debugger menu and got the same message.

“An error occurred in retrieving update information. Please try again later.”

I ran check for updates again (while typing this post) and got this:

“You’re up to date!
Script Debugger 8.0.3 is currently the newest version available.
(You are currently running version 8.0.4.)”

→ Script Debugger 8.0.4 (8A50)
→ MacOS 11.6.4

Update: This may be causing an issue.

After a restart for what I thought was an unrelated issue, when I tried to launch SD I got the same message (although this time it said 3 days).

The first time it came up I clicked Check for updates and SD hung and I had to force quit. After that, again, the mac was in an unstable state (couldn’t type in documents, sometimes no response to clicking in the dock or menus). I shutdown the mac and started again.

Launching SD, this time I hit Continue when the update alert came up and again SD hung. Before force quitting I took a sample and saved it, but I couldn’t type anything in the save dialog. Looks like my mac may again be unstable.

(FWIW, the reason I was launching SD was that a droplet I’ve been using now returns an error that it’s not allowed access to control Finder. Checking preferences it clearly is. The applet was recently moved into another folder and back to its original if that makes a difference. I was going to edit it in SD and see if that fixed it. I’ll give up on SD for a while and try SE instead).

Right now my Mac has several issues that all seem to have started when the expiring build alert came up. First, FastScripts is broken. The menu icon is just the spinning day icon.

Second, BBEdit is broken. On each launch it hangs and has to be force quit.

Third, some of the scripts that run for FastScripts aren’t running in the AppleScript Menu and since Fourth, Script Debugger is down I can’t fix them.

Rebooting in safe mode and then again out of safe mode make most of the issues go away.

I’m not going to try launching SD again, until my work is done.


I tried relaunching SD from my laptop and I got the alert, but no hang or crash or instability.

First time, I clicked check for updates and it reported I was up to date, and continued launching when that was cleared.

Tried a second time and clicked continue and it worked.

→ Script Debugger 8.0.4 (8A50)
→ Mac OS 11.6.3 (20G415)

I expect ScriptDebugger was an innocent bystander to some other issue on your system,

Script Debugger 8.0.4 has been released: