Error in SD Notary

I get the following error when trying to notarize an AppleScript app (first two lines are for context only):

11:45:18.092: Making zip archive...
11:45:19.673: Uploading file to Apple for notarizing. This can take a while, depending on file size, upload speed, and any other uploads in progress. Do not interrupt this process...
11:45:30.744: Error 105553138954000 in xcrun altool --notarize-app.

This happens to a small (150 line) script, made to an app with osacompile. I also tried this on another script that is unchanged since I have released it (then SD Notary worked fine) and I get the same error.

One change is I had to update XCode to the newest release. I’m on Big Sur and everything is up to date. I can’t run SD Notary on my other computer, since that one is still on Mojave and SD Notary isn’t supported there.

How can I fix this?

Launch Xcode, and in Preferences → Locations, make sure Command Line Tools points to the appropriate version.

It was already pointing to the right (and only) version.

You’re not running Little Snitch or similar?

SD Notary is supported on 10.13.6 and later, although 10.14 and later is preferred.

I am running Little Snitch. With network filtering turned off, the error message is slightly different:

15:11:25.717: Making zip archive...
15:11:25.885: Uploading file to Apple for notarizing. This can take a while, depending on file size, upload speed, and any other uploads in progress. Do not interrupt this process...
15:11:38.545: Error 105553128465264 in xcrun altool --notarize-app: 2021-06-24 15:11:30.313 altool[14859:205714] -[__NSCFString objectForKeyedSubscript:]: unrecognized selector sent to instance 0x7fec32e536d0

Quitting with the network filtering turned off didn’t change this error message.

For what it’s worth: I couldn’t download XCode from the app store on my Mojave machine. I didn’t try anything else.

The error is being produced in Apple’s altool, and it still smells like a communications problem.

You can see from the log what the command and arguments being used are, and if you sign-only, you can try it manually via Terminal with an archive of the signed file. You should see the same error.

Got to the developer downloads page and download one of the earlier versions, such as Xcode 10.x.

I’ve downloaded XCode 10.3, and started it and installed the new components.

Created a new app specific password, added it to Keychain, setup SD Notary. I double checked everyhing three times, however I get this error:

17:23:39.154: Checking if Apple ID, key for app-specific password in login keychain, and team provider are in sync...
17:23:39.612: Unknown problem using altool. Check that the app-specific pasword, Apple ID, and team provider name are correct.

Can you log into your developer account and check that you don’t have any agreements outstanding?

That last error follows an attempt to get your notarization history (--notarization-history), which requires your id, the app-specific password, plus you provider/team short name if you need one (I presume you’ve checked this by clicking the Choose… button).

If you still have no luck, try a test Xcode project. Choose New -> Project -> AppleScript App and save it somewhere. Then choose Product -> Archive. This should eventually open the Organizer window (or open it yourself from the Window menu). With your app selected, click Distribute App and follow the instructions. When it asks you, choose manual rather than automatic management of signing. No profile. It should upload, and eventually get notarized.

If it fails, try Distribute App again, this time selecting automatic management of signing.

Let me know how it goes.

I did have some agreements outstanding. Agreeing with them did change a thing though…

I haven’t filled in a provider short name. I don’t belong to multiple teams. Besides, the “Choose” button is disabled.

In Xcode I followed your instructions (method: Development). When I press “Export”, the app is saved locally. While in the wizard, it communicates with Apple. However, I don’t see it actually uploading anything, or see any progress. It seems to be done directly.

When I inspect the exported app with Apparency, it hasn’t been notarized (it says: CSSMERR_TP_NOT_TRUSTED).

I’ve tried manual and automatic signing.

If you’re still getting the “unknown problem using altool” message, try this:

That doesn’t sound right. Did you get asked to upload?

One more suggestion: make another test document in Xcode, this time just an App. Try again. If it fails, log in to the developer site and request support. Apple provides for this, but it’s better not to mention AppleScript – it tends to confuse them.

After being away for a week, SD Notary just works on my main computer. The only thing I did was switch this computer on, because it was turned of. But I also rebooted my computer while testing, so this is a bit of a mystery.

My Mojave notebook also works now. I tried the solution @emendelson was sharing, but it didn’t work (but thanks anyways). I think the problem was Xcode.app was still in the Downloads folder. I just moved it to Programs. My Mojave machine also works now.

BTW: pressing Export in the proposed Organizer workflow doesn’t ask me to upload anything. I’m not going to try other this now, since it works now. This took a bit too much time. Thanks for the help anyways.

Edit: I noticed SD Notary on my Mojave machine not saving the Apple ID and Name of app-specific password. Even after a succesful notarization. How can I make this work?

Could be — that can result in issues for any app.

Choose File -> Set Document Defaults.

That works. I remember previously there where checkboxes for every input element. That’s why I probably missed this option.

Thanks for all the help Shane!