Crash on launch

I’ve got a situation where a buggy app started SD6 crashing and now it crashes on startup whether I open old documents or not. I’m running 10.11.6.

Here’s what the Console has:
Process: Script Debugger [378]
Path: /Applications/Script Debugger
Identifier: com.latenightsw.ScriptDebugger6
Responsible: Script Debugger [378]
11 com.latenightsw.ScriptDebugger6 0x0000000101c07e59 OpenDocumentHandler(AEDesc const*, AEDesc*, void*) + 237
20 com.latenightsw.ScriptDebugger6 0x0000000101be6604 start + 52
0x101be5000 - 0x101d2afff +com.latenightsw.ScriptDebugger6 (6.0.1 - 6A180) <96FFC91D-D0EF-3D8B-A7C5-4037125339BD> /Applications/Script Debugger
0x101e71000 - 0x10209cff7 +com.latenightsw.RosieKit2 (1.0 - 1) <680FE028-84C9-3904-BC37-9CD323260FFE> /Applications/Script
0x1021ac000 - 0x102241fff +com.latenightsw.LNSAppKit (1.0) <87339024-A79E-3783-A163-B4125B4B6C8F> /Applications/Script
0x1022a9000 - 0x1022b9fff +com.latenightsw.ScriptDebuggerKit (6.0.1 - 6A180) <38C37F55-E2F3-3D51-8F41-C2D16759F888> /Applications/Script
0x1022cd000 - 0x102308fff +org.sparkle-project.Sparkle (1.13.1 git-2afc553 - 1.13.1) <40414915-A48C-3DBB-AACB-5C20BAAE6DA6> /Applications/Script
0x10b7f4000 - 0x10b895ff7 +com.latenightsw.ScriptDebuggerNub (126 - 126) <6EC10696-CAB5-313E-A297-3CDA907B4B64> /Users/USER/Library/Components/*/Script Debugger

Which is admittedly pretty minimal. I’ve tried pulling all the prefs and app support files. There must be something else being accessed on startup.


Try holding down the Shift key when you launch SD6 and see if that helps.

The crash reports I’m receiving from you on this issue look mostly like this:

Thread 0 Crashed:: Dispatch queue:
0   libsystem_kernel.dylib        	0x00007fff9c190f06 __pthread_kill + 10
1   libsystem_pthread.dylib       	0x00007fff894424ec pthread_kill + 90
2   libsystem_c.dylib             	0x00007fff8d7ce6df abort + 129
3   libc++abi.dylib               	0x00007fff97a75c11 abort_message + 257
4   libc++abi.dylib               	0x00007fff97a9be17 default_terminate_handler() + 267
5   libobjc.A.dylib               	0x00007fff922574a6 _objc_terminate() + 124
6   libc++abi.dylib               	0x00007fff97a9900e std::__terminate(void (*)()) + 8
7   libc++abi.dylib               	0x00007fff97a98c8f __cxa_rethrow + 99
8   libobjc.A.dylib               	0x00007fff92253c23 objc_exception_rethrow + 40
9          	0x00007fff97c1b802 -[NSAppleEventManager dispatchRawAppleEvent:withRawReply:handlerRefCon:] + 503
10          	0x00007fff97c1b5a7 _NSAppleEventManagerGenericHandler + 102
11  com.latenightsw.ScriptDebugger6	0x000000010297ce59 OpenDocumentHandler(AEDesc const*, AEDesc*, void*) + 237
12                  	0x00007fff9c360261 aeDispatchAppleEvent(AEDesc const*, AEDesc*, unsigned int, unsigned char*) + 531
13                  	0x00007fff9c35ffe8 dispatchEventAndSendReply(AEDesc const*, AEDesc*) + 31
14                  	0x00007fff9c35ff04 aeProcessAppleEvent + 288
15           	0x00007fff96a55af9 AEProcessAppleEvent + 55
16              	0x00007fff8b964290 _DPSNextEvent + 2245
17              	0x00007fff8b963226 -[NSApplication _nextEventMatchingEventMask:untilDate:inMode:dequeue:] + 454
18              	0x00007fff8b957d80 -[NSApplication run] + 682
19              	0x00007fff8b921368 NSApplicationMain + 1176
20  com.latenightsw.ScriptDebugger6	0x000000010295b604 start + 52

Some sort of uncaught exception is being thrown in the Cocoa code that responds to open document AppleEvents. This does not really get us anywhere other than the suspicion that the Open Document AppleEvent may be malformed.

You have probably done all this, but try removing these items:

  • ~/Library/Preferences/com.latenightsw.ScriptDebugger6.plist - note that this will cause Script Debugger to prompt for your registration number when launched
  • ~/Library/Preferences/com.latenightsw.ScriptDebugger6.LSSharedFileList.plist
  • ~/Library/Autosave Information/com.latenightsw.ScriptDebugger6.plist

Here is a debug build of Script Debugger. It will log all kinds of stuff to the console. Perhaps something useful will appear:

Removing the Autosave folder did it. The saved script still crashes SD, so I crashed the debug build and have attached a zip with Console output and the offending script. The script is benign, but I think the app returned some bogus data, which has since been fixed, so I think the saved result is the likely culprit. We’ll see.


Jon (24.9 KB)

…which is exactly what you would have achieved if you’d just launched SD with the Shift key held down… :wink:

Except for the part where I tried that and it didn’t stop the crash.


Yeah, my bad.

I mistook the reference to AutoSave Information folder as a reference to Saved Application State folder. It’s the latter that holding down the Shift key sidesteps.

I’m not sure at the moment what role the Autosave Information folder plays on launch or if there’s an easy way to sidestep it (aside from deleting it, as you did, of course).