Compiled Script saves as a folder

Hi all,

I don’t know if this is SD related or some pref on my mac not setup properly but SD now create a FOLDER when I save my script as “compiled script” (which has other files added to its bundle).

But only when I do SAVE AS. If I simply SAVE, everything is ok.
Also, I do not get the REPLACE warning when doing so.

Note that I recently got a new MacBook now running Big Sur.


There’s an issue in Big Sur where, when you do a save as and change the file type, the extension is not changed accordingly. The result is what you see. Until we get a new version released, the solution is to manually fix the extension in the save dialog.

Thanks Shane,

Geez, it has been a while when was Aspro New Orleans? 2006?

Actually, I did not do a file type change, only the name.

Coincidently, can I contact you w/r to a problem I am having with Indesign?

So a compiled script called <whatever>.scpt saved as <something_else>.scpt? I can’t reproduce that here.

Fell free to post questions in the forums here. Alas, I do very little InDesign scripting these days, so I’m not really the person to ask.

(Yes, 2006…)

New Orleans was 2002. You guys are old. :slight_smile:

My memory is Michel led a group out for karaoke one night, though Shane and I did not go.

In 2006, Shane made me ride a bike through Manhattan and beyond. I think that was the (only?) time Mark joined us via video. But a lot more happened on that trip.

Note that this issue is resolved in the current Script Debugger 7.0.13 beta build.

I don’t recall if that was the same night we all went to “Apollo 13” at the IMAX, or another night. Seems to me Michel went solo after the movie… And if memory serves, the suite Shane had at the hotel was, well, pretty sweet, pun intended. The Ponchartrain.


I finally got back to this (you know how that goes) and after a few searches it appears that you had already provided a solution to my problem… :wink:

In short, one of my old InDesign scripts stopped being able to relink images after upgrading to MacOS Catalina. While I am still not sure how that bug came to be, why hasn’t this been solved by Adobe and why does Shane’s solution work.

But setting my variable to path_to_file as «class furl» outside of InDesign brought my script back to life.

Thank you for that