Code folding pasting doesn't seem to work

If I have a handler in one script that’s folded and I want to paste it into another script it seems that it doesn’t work. I have to unfold the handler first and then paste it.

Is that a new behavior?

Can you, um, expand on that? I just tried a simple test, with no problem.

Hmmm… I tried it again and it worked. I’ll try to recreate the scenario when I’m off deadline.

Basically it was an InDesign script that errored. When I opened it the script had some (not all) InDesign commands in raw AE code <<>> and wouldn’t compile.

I tried displaying raw syntax and turning that off (which has worked before) but it didn’t help.
I was trying to copy the handlers one by one to a new script and that’s where the issue was.

It’s possible it could fail if it’s pasted at a point that makes the script unbalanced (as in blocks without any end statement).

If you can reproduce this, please capture a video of the screen as you go through the process. There may be some subtle thing you are doing that we are not that may help us reproduce the behaviour your are experiencing.