Clippings not updating live

This is odd. It used to be that if I added a clipping file to the clipping folder it would be available immediately.

That doesn’t seem to be the case any longer.

It still should be the case.

Nope, not the case here. (although I tried it on my laptop and it seemed to work there).

If I add a file to clippings, then relaunch SD I can see it.

(I did relaunch SD and try again and still no update, I’ll try with Scripts folder next).

–> Script Debugger 7.0.12 (7A112)
–> Mac OS 10.11.6 (15G22010)

Here’s my experience today.

Clippings menu was not updating until relaunch. This happened several times to day through several relaunches. After relaunch the folder had updated…

And now it’s behaving differently.

After relaunch: Opened clippings folder in finder, duplicated a clipping.

Opened SD again and the duplicate wasn’t in the clippings menu.

Opened Scripts folder in Finder. Duplicated a script.

Opened SD again and the duplicated script was in the scripts menu.

The duplicated Clipping was not in the clippings menu.

Opened the Clipping folder again in finder, duplicated another clipping,

Opened SD again and both duplicated clippings appeared in the clipping menu.

Tried one more time and a third duplicated scripting appeared in clipping menu. (no relaunch required)

So it seems to have fixed itself?

I’ll toy around and see if there’s some way to reproduce.

Script Debugger is relying on the OS reporting the right thing. In this case it sounds like that’s not happening reliably, in which case a restart is probably the best course of action.

Relaunched and removed all those extra script copies I made and it instantly updated.