Change font attributes in preferences

I can’t seem to change font attributes in the Font preferences. I remember being able to do so not so long ago. Specifically, I’m trying to set an underline for keywords. I have access to that in the interface but the apply button stays greyed out.

It should be enabled once you bring up either the font or color picker and make a change. Have you made a change there?

Yes, I changed to underline keywords but I did not get the Apply button. I did get it when I changed the font size of name or type though.

Weirder. It used to be that such settings were shared by SE and SD, so that when I set this in SE it is also applied in SD, but now SD seems to have precedence and resets the settings…

They still are, but what happens when you change them while both are running can vary.


Here is what I have. The settings with the underline are properly displayed in SE, but not in SD. Although the compiled file opens in SD with the proper underlining.

Yes, you’re limited to dealing with the font, size and color in Script Debugger.

Oh. Ok. Why ? And why can’t it display the settings properly even if it can’t change them?

My guess is that the interface was designed at a time when font, size and color were the only things that could be changed, and that up until now no-one has noticed or complained.

1 Like

Is it possible to put that as a feature request ?

Please test the next release candidate when it drops.

1 Like