Can't turn of "Show Startup Screen" option for save

I had a script file saved as as a “compile script.” The Application Option “Show Startup Screen” was checked but it was also dimmed. I didn’t want this option on. Since I started out trying to convert my script to a “compile script bundle” i went ahead and saved the file as a “compiled script bundle”. When I chose “Save As” from the file menu again the option was still dimmed. I uploaded the script that was saved to disk (Untitled.scptd) and an image of the save dialog with the dimmed option. (4.5 KB)


It doesn’t matter whether it’s checked or not – the setting is ignored for any format other than .app files.

I know it doesn’t do anything different unless it’s an Applet but don’t you think that might frustrate a user that doesn’t know that?


No more than any other disabled value. And it is clearly labeled Application Options:.

I think that if someone knows what Show Startup Screen does, they probably know it applies only to things that start up – apps. But if they don’t, a couple of minutes’ reflection on what it could possibly do if enabled on a bundle should answer the question for them anyway.

You have a point. A startup screen displays at launch. It’s pretty hard to launch something from an editor that can at best only be run. Or put another way if you know enough to get confused you know enough to eventually figure it out : )