"Cannot Save Document - File is busy (delete) (fBsyErr:-47)" when trying to save as Application

(Sean Murphy) #1

All of a sudden Script Debugger (7.0.7) started throwing this error any time I try to save an Application:
Cannot Save Document
File is busy (delete) (fBsyErr:-47)

I haven’t changed anything with my process recently. I did have five or six apps open and editing (making similar change to all apps) at the time that one app first threw this error. The previous five apps saved fine but this last one erred. Now, I can’t save ANY applications without getting this error.

I tested out saving in different formats and .SCPT files are saving fine but not .APP. Any ideas? I uninstalled Script Debugger, reset preferences and restarted my computer but it is still behaving the same. I’m unfortunately at a stand-still because of this. :frowning_face:

0 Likes

(Mark Alldritt) #2

Have you tried running DiskUtility’s First Aid feature on your disk(s) to see if there has been some sort of disk corruption?

0 Likes

(Sean Murphy) #3

I have not. Will give that a try. Though, I just switched to a completely different computer (even running a different OS) and got the exact same error over there. So strange.

0 Likes

(Mark Alldritt) #4

If you like, you can send me an example privately and I’ll test from my end. Just put the script in a zip archive and attach that to the message.

0 Likes

(Sean Murphy) #5

Thing is it isn’t just a specific app package. I have created a new application and literally only put in a commented-out line or basic display dialog message and all are giving the same error. Seems to be the .app package format specifically since .scpt is saving without issue.

Just did the DiskUtility First Aid and no issues were found.

0 Likes

(Mark Alldritt) #6

Do you have something like CleanMyMac installed which monitors for app deletions? I’m thinking there may be some background task on your systems which is locking folders on you.

Does the problem persist if you save the applet/bundle to different locations on your drive? I’m grasping here as I don’t have many good ideas to offer.

0 Likes

(Sean Murphy) #7

Looks like the issue was caused by a 3rd party app that my org updated on Friday. They provided a command to stop that app from working and I am able to save .apps again. Thank god! Sorry to have bugged you on here for an issue that my org made/wasn’t Script Debugger related.

1 Like