ANNOUNCE: SD Notary 2.0 (102) BETA

A new SD Notary 2 BETA build is available. You can update using the Check For Updates command in the SD Notary menu or you can download it here:

SD Notary 2 Release Notes

Build 102 Changes:

  • Fixed incorrect version check of Xcode.

  • Xcode will now only be launched when a new version has been installed.

  • The Help menu will now take you to the Release Notes.

1 Like

Not sure if this is a me thing or a SDNotary thing, but when I installed and launched SDN2 (102) an Xcode window opened on a page about help documentation. I quit Xcode and quit and relaunched SDN2 and Xcode didn’t open. Everything seemed fine. Help menu worked taking me to release notes. Thanks!

I think this text, describing submitting an app, .dmg or .pkg file is a little confusing.

I think what it’s trying to say is that if you submit a .dmg or .pkg, it the contents will not be code signed, and will have to be code signed before they are submitted.

Submit an application to be notarized, and staple it if approved. If you pass a .app, .plugin, .fmplugin, or .action file, its contents will first be code-signed in the correct order. If you pass a .dmg or .pkg file, only it will be signed — the contents will need to have been signed first. This command takes a long time to return, so it usually needs to be called within a timeout block with a very large value.

Also the part about the timeout is a bit wonky. Apple fails to notarize after a timeout of 1800 seconds. If that’s consistent a timeout longer than that is useless, right?

For what it’s worth, I’m enthusiastic about SD Notary and was looking to switch over to the 2.0 beta before November, particularly since I’ll have to fuss with passwords and such to set up the new version (doesn’t look like it’ll pick up on the 1.0 settings, as described).

I’ve clicked on the zip link up top, but nothing happens (the previous beta gives a ‘we can’t find that’ error page). Perhaps another version is out, or the download’s not working?

This link is working for me, maybe it’s fixed? Double check your downloads.

Ah, it’s claiming that it can’t be downloaded securely. An interesting problem to run into with a notary app! I did in fact get the zip, and it produced the app. The app is signed and runs, and I’m walking through my usual weekly codesigning routine. It’s failed once before ‘awaiting’ as I had an agreement to re-accept, and a second time during ‘awaiting’ with the same issue, and the third time appears to have worked. I think I’m good to go :slight_smile:

1 Like

I tried the original link in Safari and Google Chrome and I’m not getting any security warnings.

You could try being explicit about HTTPS:

Oh! That was it. I’ve had to re-do my entire website to handle Chrome’s desire to have everything be https. That’s all it was. Beta is working great so far, everything seems good :slight_smile: