Pausing at first executable statement

sd7

#1

I’ve just started running SD 7 in trial mode, while waiting for my code to upgrade from SD 6 (recent purchase). In debugging mode, when I click the Execute button in the toolbar, or select Execute from the Script menu, SD7 pauses at the first executable statement. If I click the button again, it proceeds normally.

Is this a bug, or a preference setting? How do I eliminate the pause at the first statement? Thanks.


(Shane Stanley) #2

I’m not sure how that crept in.


(Mark Alldritt) #3

I’m trying to reproduce the problem you are experiencing without any success.

There are two ways to run a script: The Execute (Command-R) command and the Step Over/Into commands. The Execute command should run your script until the script ends, your issue the Pause command, or your script hits a breakpoint. The Step Over/Into commands will pause immediately on the very first statement.

Would it be possible for you to capture a movie showing the steps you are using to execute your script? I’m very curious to see exactly what you are doing to cause Script Debugger to fail in this way.


#4

Screen recording uploaded to:

https://expirebox.com/download/ff0556bd177f6f7822ad5e17785f4ce9.html


(Shane Stanley) #5

@LagunaHiker, this will be addressed in an upcoming maintenance release. In the meantime, we see that it only happens when Persistent Properties is turned off for a script. So depending on what you are doing, turning Persistent Properties on for a script is a workaround.